<!DOCTYPE html>
<html class="no-js" lang="en-US"
	prefix="og: https://ogp.me/ns#" >
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="https://www.escondidograpevine.com/xmlrpc.php" />
<title>Justice for Rosie’s: Hit-run suspect arrested | Escondido Grapevine</title>

		<!-- All in One SEO 4.0.12 -->
		<link rel="canonical" href="https://www.escondidograpevine.com/2021/01/12/justice-for-rosies-hit-run-suspect-arrested/" />
		<meta property="og:site_name" content="Escondido Grapevine | Breaking News, Politics, Calif." />
		<meta property="og:type" content="article" />
		<meta property="og:title" content="Justice for Rosie’s: Hit-run suspect arrested | Escondido Grapevine" />
		<meta property="og:url" content="https://www.escondidograpevine.com/2021/01/12/justice-for-rosies-hit-run-suspect-arrested/" />
		<meta property="article:published_time" content="2021-01-12T09:08:33Z" />
		<meta property="article:modified_time" content="2021-01-12T09:41:18Z" />
		<meta property="twitter:card" content="summary" />
		<meta property="twitter:domain" content="www.escondidograpevine.com" />
		<meta property="twitter:title" content="Justice for Rosie’s: Hit-run suspect arrested | Escondido Grapevine" />
		<script type="application/ld+json" class="aioseo-schema">
			{"@context":"https:\/\/schema.org","@graph":[{"@type":"WebSite","@id":"https:\/\/www.escondidograpevine.com\/#website","url":"https:\/\/www.escondidograpevine.com\/","name":"Escondido Grapevine","description":"Breaking News, Politics, Calif.","publisher":{"@id":"https:\/\/www.escondidograpevine.com\/#organization"},"potentialAction":{"@type":"SearchAction","target":"https:\/\/www.escondidograpevine.com\/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"Organization","@id":"https:\/\/www.escondidograpevine.com\/#organization","name":"Escondido Grapevine","url":"https:\/\/www.escondidograpevine.com\/"},{"@type":"BreadcrumbList","@id":"https:\/\/www.escondidograpevine.com\/2021\/01\/12\/justice-for-rosies-hit-run-suspect-arrested\/#breadcrumblist","itemListElement":[{"@type":"ListItem","@id":"https:\/\/www.escondidograpevine.com\/#listItem","position":1,"item":{"@type":"WebPage","@id":"https:\/\/www.escondidograpevine.com\/#item","name":"Home","description":"Breaking News, Politics, Calif.","url":"https:\/\/www.escondidograpevine.com\/"},"nextItem":"https:\/\/www.escondidograpevine.com\/2021\/#listItem"},{"@type":"ListItem","@id":"https:\/\/www.escondidograpevine.com\/2021\/#listItem","position":2,"item":{"@type":"CollectionPage","@id":"https:\/\/www.escondidograpevine.com\/2021\/#item","name":"January 12, 2021 | Escondido Grapevine","url":"https:\/\/www.escondidograpevine.com\/2021\/"},"nextItem":"https:\/\/www.escondidograpevine.com\/2021\/01\/#listItem","previousItem":"https:\/\/www.escondidograpevine.com\/#listItem"},{"@type":"ListItem","@id":"https:\/\/www.escondidograpevine.com\/2021\/01\/#listItem","position":3,"item":{"@type":"CollectionPage","@id":"https:\/\/www.escondidograpevine.com\/2021\/01\/#item","name":"January 12, 2021 | Escondido Grapevine","url":"https:\/\/www.escondidograpevine.com\/2021\/01\/"},"nextItem":"https:\/\/www.escondidograpevine.com\/2021\/01\/12\/#listItem","previousItem":"https:\/\/www.escondidograpevine.com\/2021\/#listItem"},{"@type":"ListItem","@id":"https:\/\/www.escondidograpevine.com\/2021\/01\/12\/#listItem","position":4,"item":{"@type":"CollectionPage","@id":"https:\/\/www.escondidograpevine.com\/2021\/01\/12\/#item","name":"January 12, 2021 | Escondido Grapevine","url":"https:\/\/www.escondidograpevine.com\/2021\/01\/12\/"},"nextItem":"https:\/\/www.escondidograpevine.com\/2021\/01\/12\/justice-for-rosies-hit-run-suspect-arrested\/#listItem","previousItem":"https:\/\/www.escondidograpevine.com\/2021\/01\/#listItem"},{"@type":"ListItem","@id":"https:\/\/www.escondidograpevine.com\/2021\/01\/12\/justice-for-rosies-hit-run-suspect-arrested\/#listItem","position":5,"item":{"@id":"https:\/\/www.escondidograpevine.com\/2021\/01\/12\/justice-for-rosies-hit-run-suspect-arrested\/#item","name":"Justice for Rosie's: Hit-run suspect arrested","url":"https:\/\/www.escondidograpevine.com\/2021\/01\/12\/justice-for-rosies-hit-run-suspect-arrested\/"},"previousItem":"https:\/\/www.escondidograpevine.com\/2021\/01\/12\/#listItem"}]},{"@type":"Person","@id":"https:\/\/www.escondidograpevine.com\/author\/the-grapevine\/#author","url":"https:\/\/www.escondidograpevine.com\/author\/the-grapevine\/","name":"The Grapevine","image":{"@type":"ImageObject","@id":"https:\/\/www.escondidograpevine.com\/2021\/01\/12\/justice-for-rosies-hit-run-suspect-arrested\/#authorImage","url":"https:\/\/secure.gravatar.com\/avatar\/aeb36b142e33d5176b83552dc85093af?s=96&d=wavatar&r=g","width":96,"height":96,"caption":"The Grapevine"}}]}
		</script>
		<!-- All in One SEO -->

<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel="alternate" type="application/rss+xml" title="Escondido Grapevine &raquo; Feed" href="https://www.escondidograpevine.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Escondido Grapevine &raquo; Comments Feed" href="https://www.escondidograpevine.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Escondido Grapevine &raquo; Justice for Rosie&#8217;s: Hit-run suspect arrested Comments Feed" href="https://www.escondidograpevine.com/2021/01/12/justice-for-rosies-hit-run-suspect-arrested/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.escondidograpevine.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.5.3"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.5.3/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mh-style-css'  href='https://www.escondidograpevine.com/wp-content/themes/mh_newsdesk/style.css?ver=1.2.0' type='text/css' media='all' />
<link rel='stylesheet' id='mh-font-awesome-css'  href='//maxcdn.bootstrapcdn.com/font-awesome/4.3.0/css/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='mh-google-fonts-css'  href='//fonts.googleapis.com/css?family=PT+Serif:300,400,400italic,600,700|Oswald:300,400,400italic,600,700' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_facebook_likebox-css'  href='https://c0.wp.com/p/jetpack/9.3/modules/widgets/facebook-likebox/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://c0.wp.com/p/jetpack/9.3/_inc/social-logos/social-logos.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/9.3/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript' src='https://c0.wp.com/c/5.5.3/wp-includes/js/jquery/jquery.js' id='jquery-core-js'></script>
<script type='text/javascript' id='jetpack_related-posts-js-extra'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/9.3/_inc/build/related-posts/related-posts.min.js' id='jetpack_related-posts-js'></script>
<script type='text/javascript' src='https://www.escondidograpevine.com/wp-content/themes/mh_newsdesk/js/scripts.js?ver=5.5.3' id='mh-scripts-js'></script>
<link rel="https://api.w.org/" href="https://www.escondidograpevine.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.escondidograpevine.com/wp-json/wp/v2/posts/23757" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.escondidograpevine.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.escondidograpevine.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Illegitimate carpetbagger Issa couldn&#8217;t have won the 50th Cong. District. We must re-vote.' href='https://www.escondidograpevine.com/2021/01/07/illegitimate-carpetbagger-issa-couldnt-have-won-the-50th-cong-district-we-must-re-vote/' />
<meta name="generator" content="WordPress 5.5.3" />
<link rel='shortlink' href='https://www.escondidograpevine.com/?p=23757' />
<link rel="alternate" type="application/json+oembed" href="https://www.escondidograpevine.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.escondidograpevine.com%2F2021%2F01%2F12%2Fjustice-for-rosies-hit-run-suspect-arrested%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.escondidograpevine.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.escondidograpevine.com%2F2021%2F01%2F12%2Fjustice-for-rosies-hit-run-suspect-arrested%2F&#038;format=xml" />
<link rel="stylesheet" type="text/css" media="screen, print" href="https://www.escondidograpevine.com/wp-content/plugins/recaptcha-form/gd-recaptcha.css" />
<style type='text/css'>img#wpstats{display:none}</style>	<style type="text/css">
    	    		.social-nav a:hover, .logo-title, .entry-content a, a:hover, .entry-meta .entry-meta-author, .entry-meta a, .comment-info, blockquote, .pagination a:hover .pagelink { color: #530060; }
			.main-nav li:hover, .slicknav_menu, .ticker-title, .breadcrumb a, .breadcrumb .bc-text, .button span, .widget-title span, input[type=submit], table th, .comment-section-title .comment-count, #cancel-comment-reply-link:hover, .pagination .current, .pagination .pagelink { background: #530060; }
			blockquote, input[type=text]:hover, input[type=email]:hover, input[type=tel]:hover, input[type=url]:hover, textarea:hover { border-color: #530060; }
    	    				.widget-title, .pagination a.page-numbers:hover, .dots:hover, .pagination a:hover .pagelink, .comment-section-title { background: #e8e8e8; }
			.commentlist .depth-1, .commentlist .bypostauthor .avatar { border-color: #e8e8e8; }
    	    	    	    	    		</style>
    <link rel="shortcut icon" href="https://escondidograpevine.com/wp-content/uploads/2017/04/Grapevine-TwitterNEW.png">
<!--[if lt IE 9]>
<script src="https://www.escondidograpevine.com/wp-content/themes/mh_newsdesk/js/css3-mediaqueries.js"></script>
<![endif]-->
<link rel="icon" href="https://i1.wp.com/www.escondidograpevine.com/wp-content/uploads/2017/04/Grapevine-TwitterNEW.png?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i1.wp.com/www.escondidograpevine.com/wp-content/uploads/2017/04/Grapevine-TwitterNEW.png?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon" href="https://i1.wp.com/www.escondidograpevine.com/wp-content/uploads/2017/04/Grapevine-TwitterNEW.png?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i1.wp.com/www.escondidograpevine.com/wp-content/uploads/2017/04/Grapevine-TwitterNEW.png?fit=270%2C270&#038;ssl=1" />
</head>
<body class="post-template-default single single-post postid-23757 single-format-standard mh-right-sb">
	<div class="header-top">
		<div class="wrapper-inner clearfix">
							<nav class="header-nav clearfix">
					<div class="menu-above-header2-container"><ul id="menu-above-header2" class="menu"><li id="menu-item-11302" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-11302"><a href="https://escondidograpevine.com">Home</a></li>
<li id="menu-item-11316" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-11316"><a href="https://www.escondidograpevine.com/about-us/">About Us</a></li>
<li id="menu-item-11315" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-11315"><a href="https://www.escondidograpevine.com/advertise/">Advertise</a></li>
<li id="menu-item-11319" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-11319"><a href="https://www.escondidograpevine.com/sitemap/">Sitemap</a></li>
</ul></div>				</nav>
								</div>
	</div>
<div id="mh-wrapper">
<header class="mh-header">
	<div class="header-wrap clearfix">
				<div class="mh-col mh-1-3 header-logo-full">
			<a href="https://www.escondidograpevine.com/" title="Escondido Grapevine" rel="home">
<div class="logo-wrap" role="banner">
<img src="https://escondidograpevine.com/wp-content/uploads/2015/10/cropped-GrapevineBannerNEW4.png" height="126" width="999" alt="Escondido Grapevine" />
</div>
</a>
		</div>
			</div>
	<div class="header-menu clearfix">
		<nav class="main-nav clearfix">
			<div class="menu-header-navigation-container"><ul id="menu-header-navigation" class="menu"><li id="menu-item-11268" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-11268"><a href="https://www.escondidograpevine.com/category/escondido/">Escondido</a></li>
<li id="menu-item-22935" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22935"><a href="https://www.escondidograpevine.com/category/rancho-santa-fe/">Rancho Santa Fe</a></li>
<li id="menu-item-11294" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11294"><a href="https://www.escondidograpevine.com/category/san-marcos/">San Marcos</a></li>
<li id="menu-item-11269" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11269"><a href="https://www.escondidograpevine.com/category/north-county/">North County</a></li>
<li id="menu-item-22939" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22939"><a href="https://www.escondidograpevine.com/category/california/">California</a></li>
<li id="menu-item-11272" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11272"><a href="https://www.escondidograpevine.com/category/politics/">Politics</a></li>
<li id="menu-item-11271" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11271"><a href="https://www.escondidograpevine.com/category/business/">Business</a></li>
<li id="menu-item-11270" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-11270"><a href="https://www.escondidograpevine.com/category/policefire/police/">Police</a></li>
<li id="menu-item-11292" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11292"><a href="https://www.escondidograpevine.com/category/sports/">Sports</a></li>
<li id="menu-item-11290" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-11290"><a href="https://www.escondidograpevine.com/advertise/">Advertise</a></li>
</ul></div>		</nav>
		<div class="header-sub clearfix">
							<section id="ticker" class="news-ticker mh-col mh-2-3 clearfix">
			<span class="ticker-title">Hot Topics</span>
		<ul class="ticker-content">			<li class="ticker-item">
				<a class="ticker-item-link" href="https://www.escondidograpevine.com/2021/01/12/justice-for-rosies-hit-run-suspect-arrested/" title="Justice for Rosie&#8217;s: Hit-run suspect arrested">
					<span class="ticker-item-date">January 12, 2021</span>
					<span class="ticker-item-separator">|</span>
					<span class="ticker-item-title">Justice for Rosie&#8217;s: Hit-run suspect arrested</span>
				</a>
			</li>			<li class="ticker-item">
				<a class="ticker-item-link" href="https://www.escondidograpevine.com/2021/01/07/illegitimate-carpetbagger-issa-couldnt-have-won-the-50th-cong-district-we-must-re-vote/" title="Illegitimate carpetbagger Issa couldn&#8217;t have won the 50th Cong. District. We must re-vote.">
					<span class="ticker-item-date">January 7, 2021</span>
					<span class="ticker-item-separator">|</span>
					<span class="ticker-item-title">Illegitimate carpetbagger Issa couldn&#8217;t have won the 50th Cong. District. We must re-vote.</span>
				</a>
			</li>			<li class="ticker-item">
				<a class="ticker-item-link" href="https://www.escondidograpevine.com/2021/01/07/covid-19-vaccine-distribution-in-california/" title="COVID-19 vaccine distribution in California">
					<span class="ticker-item-date">January 7, 2021</span>
					<span class="ticker-item-separator">|</span>
					<span class="ticker-item-title">COVID-19 vaccine distribution in California</span>
				</a>
			</li>			<li class="ticker-item">
				<a class="ticker-item-link" href="https://www.escondidograpevine.com/2021/01/06/battered-california-gop-struggles-to-survive/" title="Battered, California GOP struggles to survive">
					<span class="ticker-item-date">January 6, 2021</span>
					<span class="ticker-item-separator">|</span>
					<span class="ticker-item-title">Battered, California GOP struggles to survive</span>
				</a>
			</li>			<li class="ticker-item">
				<a class="ticker-item-link" href="https://www.escondidograpevine.com/2021/01/04/mare-waldron-is-days-late-and-dollars-short/" title="Marie Waldron is days late and dollars short">
					<span class="ticker-item-date">January 4, 2021</span>
					<span class="ticker-item-separator">|</span>
					<span class="ticker-item-title">Marie Waldron is days late and dollars short</span>
				</a>
			</li>			<li class="ticker-item">
				<a class="ticker-item-link" href="https://www.escondidograpevine.com/2021/01/04/in-with-the-3-new-sd-county-supervisors/" title="In with the 3 new SD County Supervisors">
					<span class="ticker-item-date">January 4, 2021</span>
					<span class="ticker-item-separator">|</span>
					<span class="ticker-item-title">In with the 3 new SD County Supervisors</span>
				</a>
			</li>			<li class="ticker-item">
				<a class="ticker-item-link" href="https://www.escondidograpevine.com/2021/01/03/follow-the-money-joel-anderson-edition/" title="Follow the money: Joel Anderson edition">
					<span class="ticker-item-date">January 3, 2021</span>
					<span class="ticker-item-separator">|</span>
					<span class="ticker-item-title">Follow the money: Joel Anderson edition</span>
				</a>
			</li>			<li class="ticker-item">
				<a class="ticker-item-link" href="https://www.escondidograpevine.com/2021/01/02/20-years-ago-heavens-gate-couldnt-wait/" title="23 years ago, Heaven&#8217;s Gate couldn&#8217;t wait">
					<span class="ticker-item-date">January 2, 2021</span>
					<span class="ticker-item-separator">|</span>
					<span class="ticker-item-title">23 years ago, Heaven&#8217;s Gate couldn&#8217;t wait</span>
				</a>
			</li>	</ul>
</section>						<aside class="mh-col mh-1-3 header-search">
				<form role="search" method="get" class="search-form" action="https://www.escondidograpevine.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>			</aside>
		</div>
	</div>
</header><div class="mh-section mh-group">
	<div id="main-content" class="mh-content"><nav class="breadcrumb"><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="https://www.escondidograpevine.com" itemprop="url" class="bc-home"><span itemprop="title">Home</span></a></span> <span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="https://www.escondidograpevine.com/category/escondido/" itemprop="url"><span itemprop="title">Escondido</span></a></span></nav>
<article id="post-23757" class="post-23757 post type-post status-publish format-standard has-post-thumbnail hentry category-escondido category-food category-grand-avenue category-media category-police category-policefire category-restaurants category-restaurants-food tag-chef-robert-irvine tag-kaitlyn-rose-pillsbury tag-north-county-san-diego-restaurants tag-reality-tv-makeover-shows tag-restaurant-impossible tag-rosies-cafe tag-the-food-network">
	<header class="entry-header clearfix">
		<h1 class="entry-title">Justice for Rosie&#8217;s: Hit-run suspect arrested</h1>
		<div class="entry-tags clearfix"><span>TOPICS:</span><a href="https://www.escondidograpevine.com/tag/chef-robert-irvine/" rel="tag">Chef Robert Irvine</a><a href="https://www.escondidograpevine.com/tag/kaitlyn-rose-pillsbury/" rel="tag">Kaitlyn Rose Pillsbury</a><a href="https://www.escondidograpevine.com/tag/north-county-san-diego-restaurants/" rel="tag">north county san diego restaurants</a><a href="https://www.escondidograpevine.com/tag/reality-tv-makeover-shows/" rel="tag">reality TV makeover shows</a><a href="https://www.escondidograpevine.com/tag/restaurant-impossible/" rel="tag">Restaurant Impossible</a><a href="https://www.escondidograpevine.com/tag/rosies-cafe/" rel="tag">Rosie's Cafe</a><a href="https://www.escondidograpevine.com/tag/the-food-network/" rel="tag">The Food Network</a></div>	</header>
<div class="entry-thumbnail">
<img width="777" height="437" src="https://i0.wp.com/www.escondidograpevine.com/wp-content/uploads/2021/01/Restaurant-Impossible-to-Rehab-HN2266-Logo-Sized.jpg?resize=777%2C437&amp;ssl=1" class="attachment-content-single size-content-single wp-post-image" alt="" loading="lazy" srcset="https://i0.wp.com/www.escondidograpevine.com/wp-content/uploads/2021/01/Restaurant-Impossible-to-Rehab-HN2266-Logo-Sized.jpg?resize=300%2C168&amp;ssl=1 300w, https://i0.wp.com/www.escondidograpevine.com/wp-content/uploads/2021/01/Restaurant-Impossible-to-Rehab-HN2266-Logo-Sized.jpg?resize=777%2C437&amp;ssl=1 777w, https://i0.wp.com/www.escondidograpevine.com/wp-content/uploads/2021/01/Restaurant-Impossible-to-Rehab-HN2266-Logo-Sized.jpg?resize=180%2C101&amp;ssl=1 180w, https://i0.wp.com/www.escondidograpevine.com/wp-content/uploads/2021/01/Restaurant-Impossible-to-Rehab-HN2266-Logo-Sized.jpg?resize=260%2C146&amp;ssl=1 260w, https://i0.wp.com/www.escondidograpevine.com/wp-content/uploads/2021/01/Restaurant-Impossible-to-Rehab-HN2266-Logo-Sized.jpg?resize=373%2C210&amp;ssl=1 373w, https://i0.wp.com/www.escondidograpevine.com/wp-content/uploads/2021/01/Restaurant-Impossible-to-Rehab-HN2266-Logo-Sized.jpg?resize=120%2C67&amp;ssl=1 120w" sizes="(max-width: 777px) 100vw, 777px" /><span class="wp-caption-text">Kaitlyn Rose Pilsbury in the Sharp Allison deRose Rehabilitation Center, and with Robert Irvine, host of the Food Network show “Restaurant: Impossible.”/Sharp Hospital</span>
</div>
<p class="entry-meta">
<span class="entry-meta-author vcard author">Posted By: <a class="fn" href="https://www.escondidograpevine.com/author/the-grapevine/">The Grapevine</a></span>
<span class="entry-meta-date updated">January 12, 2021</span>
</p>
	<div class="entry-content clearfix">
		<blockquote><p><strong>Rene Solorio, 35, sits at the Vista Jail today, charged with the alleged December 2019 hit-and-run crash that seriously injured Kaitlyn Rose Pillsbury, proprietress of Rosie&#8217;s Cafe as featured on the Food Network&#8217;s &#8220;Restaurant Impossible&#8221; show hosted by Chef Robert Irvine.</strong></p></blockquote>
<p>Solorio, a Vista resident, remained jailed in lieu of $200,000 bail Monday, a week after he was taken into custody on a Jan. 4 warrant. Sheriff&#8217;s officials made the announcement Monday, Jan. 11, but didn&#8217;t say why they delayed the reveal a week.</p>
<p><a href="https://www.nbcsandiego.com/news/local/community-unites-for-hit-and-run-victim-escondido-cafe-owner/2236767/" target="_blank" rel="noopener noreferrer">A white Ford Explorer</a> struck Pillsbury as she was riding her Harley Davidson motorcycle through Vista just before Christmas. The hit-and-run driver veered his SUV into her at a gas station intersection and fled on foot.</p>
<p>Pillsbury’s injuries were serious to the max. She was in coma for some time with a serious head injury and broken bones in her legs and one arm. After three months in the hospital and numerous surgeries, she was released to outpatient physical therapy in late February 2020.</p>
<p>Irvine originally hooked up with Rosie in January 2019 when his restaurant makeover show visited the Cafe and did its thing. Unfortunately, the combination of Rosie&#8217;s injuries and a post-COVID economic environment spelled the end of the restaurant that occupied the historic former site of Champion&#8217;s Restaurant at 117 W. Grand Ave. in downtown Escondido.</p>
<p><a href="https://www.sandiegouniontribune.com/communities/north-county/escondido/story/2020-02-06/restaurant-impossible-plans-benefit-carnival-for-injured-escondido-cafe-owner" target="_blank" rel="noopener noreferrer">In an interview</a> last April, Irvine said that reinventing Rosie’s Cafe at 117 W. Grand Ave. was one of his favorite episodes of “Restaurant: Impossible,” a series that aired on Food Network from 2011 to 2016 and then re-launched in Spring 2019 with the Rosie’s episode as its premiere. The British chef is known for his tough-as-nails personality.He said Pilsbury was equally tough and resistant to change, but he eventually won her over.</p>
<p><iframe title="&#039;Restaurant Impossible&#039; special helping Escondido&#039;s Rosie&#039;s Cafe owner to air on Food Network" width="777" height="437" src="https://www.youtube.com/embed/WHGz3lP7gVg?feature=oembed" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p>
<div class="user-generated clearfix journal-body fade-out-medium" data-qa-id="5e3c7e1cc34e7b05408b4a1d-journal-entry-body">
<div class="user-generated clearfix journal-body fade-out-medium" data-qa-id="5e34cfea98f6cf4f7eba0e4d-journal-entry-body">
<div>
<p>“Makeovers are tough, period,&#8221; Irvine said, &#8220;but this one was tough emotionally because I truly believe in her and she’s inspiring to me. It’s the first one in many episodes where I really wanted her to succeed. I wanted to teach her. I wanted to get through to her.&#8221;</p>
</div>
</div>
</div>
<p>Just before COVID-19 changed everything, this final reality<a href="https://www.escondidograpevine.com/2020/05/23/rosies-cafe-back-on-food-network-thursday/" target="_blank" rel="noopener noreferrer"> TV show installment</a> in the Rosie’s Cafe saga was recorded during a fundraising extravaganza held Feb. 17, 2020 at Grand Avenue and Maple Street.</p>
<p>The carnival had a New Jersey theme, in honor of <a href="https://www.rosiescafeongrand.com/" target="_blank" rel="noopener noreferrer">Cafe</a> owner Kaitlyn Rose “Rosie” Pilsbury’s heritage, and included food booths, arcade games and rides. General admission tickets were $20. Children under 3 were free. All proceeds went to the Pilsbury family.</p>
<p>The event itself raised over $120,000 for Pilsbury, 34. Of that, The Food Network donated $50,000 and Irvine donated $20,000.</p>
<p>Pillsbury sustained a traumatic brain injury (TBI) as well as broken bones in her legs and arms due to the hit-and-run crash. After weeks on a ventilator and several surgeries, she was transferred to the <a id="https://www.sharp.com/hospitals/memorial/departments/rehab.cfm|" href="https://www.sharp.com/hospitals/memorial/departments/rehab.cfm" target="_blank" rel="noopener noreferrer">Sharp Allison deRose Rehabilitation Center</a>.</p>
<p>When Pillsbury arrived, she had difficulty walking and communicating. The young, vibrant woman who could once craft gourmet sandwiches in 30 seconds, couldn’t hold a knife or understand a recipe. The rehabilitation team had to develop a specific treatment plan to help Kaitlyn regain her skills.</p>
<p>“With every patient, the initial focus of our treatment plan varies widely, based on the severity of a patient’s injury,” Lori Davidson, Pillsbury&#8217;s physical therapist said. “Sometimes patients need to focus on very basic motor skills, such as being able to sit or stand, before they can address skills related to their previous recreation or employment.”</p>
<p><a href="https://www.sharp.com/health-news/young-restaurant-owner-thrives-after-hit-and-run-accident.cfm" target="_blank" rel="noopener noreferrer">Pillsbury had to start with the basics</a>: sitting up in bed, getting around in a wheelchair, weight training to build her core strength, and walking with a walker and, then finally, a cane. She was wearing a neck brace and soft cast on her arm during this time. After almost three weeks, she was ready for the real test: the kitchen.</p>
<p>The intrepid Rosie&#8217;s Cafe proprietress wanted to make biscuits and gravy — one of her favorite recipes. Her therapists accompanied her to the grocery store — not only to gather ingredients, but also to evaluate her walking ability, balance, vision, memory and money management.</p>
<p>“Kaitlyn was dynamic and energetic,” Bernadette Gore, her recreation therapist said. “She knows her recipes and it was fun watching her work. And her biscuits and gravy were delicious.”</p>
<p>Today, Kaitlyn is walking without assistance and continues to get stronger each day. But with the impact of so much change in her life, along with the current pandemic, Rosie’s Café bit the dust.</p>
<div id="attachment_17474" style="width: 1034px" class="wp-caption aligncenter"><img aria-describedby="caption-attachment-17474" loading="lazy" class="size-large wp-image-17474" src="https://i2.wp.com/www.escondidograpevine.com/wp-content/uploads/2019/04/D4ozYPJWsAEpeoL.jpg-large.jpeg?resize=777%2C583&#038;ssl=1" alt="" width="777" height="583" srcset="https://i2.wp.com/www.escondidograpevine.com/wp-content/uploads/2019/04/D4ozYPJWsAEpeoL.jpg-large.jpeg?resize=1024%2C768&amp;ssl=1 1024w, https://i2.wp.com/www.escondidograpevine.com/wp-content/uploads/2019/04/D4ozYPJWsAEpeoL.jpg-large.jpeg?resize=300%2C225&amp;ssl=1 300w, https://i2.wp.com/www.escondidograpevine.com/wp-content/uploads/2019/04/D4ozYPJWsAEpeoL.jpg-large.jpeg?resize=768%2C576&amp;ssl=1 768w, https://i2.wp.com/www.escondidograpevine.com/wp-content/uploads/2019/04/D4ozYPJWsAEpeoL.jpg-large.jpeg?w=1260&amp;ssl=1 1260w" sizes="(max-width: 777px) 100vw, 777px" data-recalc-dims="1" /><p id="caption-attachment-17474" class="wp-caption-text">Restaurant makeover specialist Robert Irvine takes Rosie&#8217;s owner Kaitlyn Rose outside to discuss some pressing diner business on Season 14 Episode 1 of Restaurant: Impossible that aired April 20, 2019 on The Food Network/Twitter</p></div>
<p>Pillsbury is not closing the door on opening another restaurant in the future, but is considering a smaller enterprise to sell her favorite pies and cheesecakes; making them is therapeutic for her. In addition, because of her experience at Sharp Allison deRose Rehabilitation Center, she feels inspired to deliver hope to other trauma survivors and become a physical therapist herself.</p>
<p>“I have moments of downtime, but I take a deep breath and know things will get better,” Pillsbury said. “I’m grateful I’m alive, continuing to heal and following my own motto: ‘Never, never quit being grateful for your life. I’m new and improved.’”</p>
<p>Solorio was arraigned last week in Vista Superior Court on one count of hit and run with death or serious injury, and faces up to four years in prison if convicted. His attorney did not respond to a request for comment.</p>
<p>The crash happened just after 8 p.m. Dec. 21, 2019. Pilsbury was riding her motorcycle, headed north on North Melrose Drive near West Vista Way, when a white Ford Explorer made a left in front of her, sheriff’s officials have said.</p>
<p>After the crash, the driver ditched the SUV and took off running. The driver was not the registered owner of the vehicle.</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-23757" class="share-facebook sd-button share-icon no-text" href="https://www.escondidograpevine.com/2021/01/12/justice-for-rosies-hit-run-suspect-arrested/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon no-text" href="https://www.escondidograpevine.com/2021/01/12/justice-for-rosies-hit-run-suspect-arrested/?share=reddit" target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-23757" class="share-linkedin sd-button share-icon no-text" href="https://www.escondidograpevine.com/2021/01/12/justice-for-rosies-hit-run-suspect-arrested/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-23757" class="share-pinterest sd-button share-icon no-text" href="https://www.escondidograpevine.com/2021/01/12/justice-for-rosies-hit-run-suspect-arrested/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-23757" class="share-twitter sd-button share-icon no-text" href="https://www.escondidograpevine.com/2021/01/12/justice-for-rosies-hit-run-suspect-arrested/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button share-icon no-text" href="https://www.escondidograpevine.com/2021/01/12/justice-for-rosies-hit-run-suspect-arrested/?share=email" target="_blank" title="Click to email this to a friend"><span></span><span class="sharing-screen-reader-text">Click to email this to a friend (Opens in new window)</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button share-icon no-text" href="https://www.escondidograpevine.com/2021/01/12/justice-for-rosies-hit-run-suspect-arrested/#print" target="_blank" title="Click to print"><span></span><span class="sharing-screen-reader-text">Click to print (Opens in new window)</span></a></li><li><a href="#" class="sharing-anchor sd-button share-more"><span>More</span></a></li><li class="share-end"></li></ul><div class="sharing-hidden"><div class="inner" style="display: none;"><ul><li class="share-tumblr"><a rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button share-icon no-text" href="https://www.escondidograpevine.com/2021/01/12/justice-for-rosies-hit-run-suspect-arrested/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span></span><span class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li class="share-pocket"><a rel="nofollow noopener noreferrer" data-shared="" class="share-pocket sd-button share-icon no-text" href="https://www.escondidograpevine.com/2021/01/12/justice-for-rosies-hit-run-suspect-arrested/?share=pocket" target="_blank" title="Click to share on Pocket"><span></span><span class="sharing-screen-reader-text">Click to share on Pocket (Opens in new window)</span></a></li><li class="share-end"></li><li class="share-telegram"><a rel="nofollow noopener noreferrer" data-shared="" class="share-telegram sd-button share-icon no-text" href="https://www.escondidograpevine.com/2021/01/12/justice-for-rosies-hit-run-suspect-arrested/?share=telegram" target="_blank" title="Click to share on Telegram"><span></span><span class="sharing-screen-reader-text">Click to share on Telegram (Opens in new window)</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon no-text" href="https://www.escondidograpevine.com/2021/01/12/justice-for-rosies-hit-run-suspect-arrested/?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp"><span></span><span class="sharing-screen-reader-text">Click to share on WhatsApp (Opens in new window)</span></a></li><li class="share-end"></li><li class="share-skype"><a rel="nofollow noopener noreferrer" data-shared="sharing-skype-23757" class="share-skype sd-button share-icon no-text" href="https://www.escondidograpevine.com/2021/01/12/justice-for-rosies-hit-run-suspect-arrested/?share=skype" target="_blank" title="Click to share on Skype"><span></span><span class="sharing-screen-reader-text">Click to share on Skype (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div></div></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div>	</div></article>            <div class="mh-share-buttons mh-group">
            	<div class="mh-col mh-1-4 mh-facebook">
            		<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://www.escondidograpevine.com/2021/01/12/justice-for-rosies-hit-run-suspect-arrested/&t=Justice for Rosie&#8217;s: Hit-run suspect arrested', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><span class="mh-share-button"><i class="fa fa-facebook fa-2x"></i>SHARE</span></a>
            	</div>
            	<div class="mh-col mh-1-4 mh-twitter">
            		<a href="#" onclick="window.open('http://twitter.com/share?text=Justice for Rosie&#8217;s: Hit-run suspect arrested -&url=https://www.escondidograpevine.com/2021/01/12/justice-for-rosies-hit-run-suspect-arrested/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><span class="mh-share-button"><i class="fa fa-twitter fa-2x"></i>TWEET</span></a>
            	</div>
            	<div class="mh-col mh-1-4 mh-pinterest">
            		<a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://www.escondidograpevine.com/2021/01/12/justice-for-rosies-hit-run-suspect-arrested/&media=https://www.escondidograpevine.com/wp-content/uploads/2021/01/Restaurant-Impossible-to-Rehab-HN2266-Logo-Sized.jpg&description=Justice for Rosie&#8217;s: Hit-run suspect arrested', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post"><span class="mh-share-button"><i class="fa fa-pinterest fa-2x"></i>PIN</span></a>
            	</div>
            	<div class="mh-col mh-1-4 mh-googleplus">
            		<a href="#" onclick="window.open('https://plusone.google.com/_/+1/confirm?hl=en-US&url=https://www.escondidograpevine.com/2021/01/12/justice-for-rosies-hit-run-suspect-arrested/', 'googleShare', 'width=626,height=436'); return false;" title="Share on Google+" target="_blank"><span class="mh-share-button"><i class="fa fa-google-plus fa-2x"></i>SHARE</span></a>
            	</div>
            </div><nav class="post-nav-wrap" role="navigation">
<ul class="post-nav clearfix">
<li class="post-nav-prev">
<a href="https://www.escondidograpevine.com/2021/01/07/illegitimate-carpetbagger-issa-couldnt-have-won-the-50th-cong-district-we-must-re-vote/" rel="prev"><i class="fa fa-chevron-left"></i>Previous post</a></li>
</ul>
</nav>
		<h4 class="widget-title related-content-title"><span>Related Articles</span></h4>
		<div class="related-content clearfix"><article class="mh-col mh-1-4 content-grid post-3309 post type-post status-publish format-standard has-post-thumbnail hentry category-food category-restaurants-food tag-escogelato tag-escondido-coffee tag-escondido-food tag-food tag-gelato-in-san-diego tag-north-county-san-diego-ice-cream tag-north-county-san-diego-restaurants tag-san-diego tag-san-diego-food">
	<div class="content-thumb content-grid-thumb"><a href="https://www.escondidograpevine.com/2016/01/16/escogelato-escondido/" title="ESCOGELATO ESCONDIDO"><img width="180" height="101" src="https://i0.wp.com/www.escondidograpevine.com/wp-content/uploads/2016/01/6a00d83451b81169e201b8d14c7d0a970c-800wi.jpg?resize=180%2C101&amp;ssl=1" class="attachment-content-grid size-content-grid wp-post-image" alt="" loading="lazy" srcset="https://i0.wp.com/www.escondidograpevine.com/wp-content/uploads/2016/01/6a00d83451b81169e201b8d14c7d0a970c-800wi.jpg?resize=180%2C101&amp;ssl=1 180w, https://i0.wp.com/www.escondidograpevine.com/wp-content/uploads/2016/01/6a00d83451b81169e201b8d14c7d0a970c-800wi.jpg?resize=260%2C146&amp;ssl=1 260w, https://i0.wp.com/www.escondidograpevine.com/wp-content/uploads/2016/01/6a00d83451b81169e201b8d14c7d0a970c-800wi.jpg?resize=373%2C210&amp;ssl=1 373w, https://i0.wp.com/www.escondidograpevine.com/wp-content/uploads/2016/01/6a00d83451b81169e201b8d14c7d0a970c-800wi.jpg?resize=120%2C67&amp;ssl=1 120w, https://i0.wp.com/www.escondidograpevine.com/wp-content/uploads/2016/01/6a00d83451b81169e201b8d14c7d0a970c-800wi.jpg?zoom=3&amp;resize=180%2C101&amp;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" /></a></div>
			<p class="entry-meta"><span><a href="https://www.escondidograpevine.com/category/food/" rel="category tag">Food</a>, <a href="https://www.escondidograpevine.com/category/food/restaurants-food/" rel="category tag">Restaurants</a></span></p>
		<h3 class="content-grid-title"><a href="https://www.escondidograpevine.com/2016/01/16/escogelato-escondido/" title="ESCOGELATO ESCONDIDO" rel="bookmark">ESCOGELATO ESCONDIDO</a></h3>
</article>
<hr class="mh-separator content-grid-separator"><article class="mh-col mh-1-4 content-grid post-15217 post type-post status-publish format-standard has-post-thumbnail hentry category-food category-grand-avenue category-restaurants category-restaurants-food category-wine-and-beer tag-dan-weisman tag-eating-san-diego tag-escondido-resraurants tag-food-network tag-restaurant-impossible-ambush tag-rosies-cafe tag-tv-food-shows tag-vinz-wine-bar">
	<div class="content-thumb content-grid-thumb"><a href="https://www.escondidograpevine.com/2019/01/23/tale-of-two-diners-rosies-in-vinzs-out/" title="Tale of two diners: Rosie&#8217;s in, Vinz&#8217;s out"><img width="180" height="101" src="https://i2.wp.com/www.escondidograpevine.com/wp-content/uploads/2019/01/rosies.jpg?resize=180%2C101&amp;ssl=1" class="attachment-content-grid size-content-grid wp-post-image" alt="" loading="lazy" srcset="https://i2.wp.com/www.escondidograpevine.com/wp-content/uploads/2019/01/rosies.jpg?resize=777%2C437&amp;ssl=1 777w, https://i2.wp.com/www.escondidograpevine.com/wp-content/uploads/2019/01/rosies.jpg?resize=180%2C101&amp;ssl=1 180w, https://i2.wp.com/www.escondidograpevine.com/wp-content/uploads/2019/01/rosies.jpg?resize=260%2C146&amp;ssl=1 260w, https://i2.wp.com/www.escondidograpevine.com/wp-content/uploads/2019/01/rosies.jpg?resize=373%2C210&amp;ssl=1 373w, https://i2.wp.com/www.escondidograpevine.com/wp-content/uploads/2019/01/rosies.jpg?resize=120%2C67&amp;ssl=1 120w, https://i2.wp.com/www.escondidograpevine.com/wp-content/uploads/2019/01/rosies.jpg?zoom=3&amp;resize=180%2C101&amp;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" /></a></div>
			<p class="entry-meta"><span><a href="https://www.escondidograpevine.com/category/food/" rel="category tag">Food</a>, <a href="https://www.escondidograpevine.com/category/escondido/grand-avenue/" rel="category tag">Grand Avenue</a>, <a href="https://www.escondidograpevine.com/category/restaurants/" rel="category tag">Restaurants</a>, <a href="https://www.escondidograpevine.com/category/food/restaurants-food/" rel="category tag">Restaurants</a>, <a href="https://www.escondidograpevine.com/category/food/wine-and-beer/" rel="category tag">Wine and Beer</a></span></p>
		<h3 class="content-grid-title"><a href="https://www.escondidograpevine.com/2019/01/23/tale-of-two-diners-rosies-in-vinzs-out/" title="Tale of two diners: Rosie&#8217;s in, Vinz&#8217;s out" rel="bookmark">Tale of two diners: Rosie&#8217;s in, Vinz&#8217;s out</a></h3>
</article>
<hr class="mh-separator content-grid-separator"><article class="mh-col mh-1-4 content-grid post-21779 post type-post status-publish format-standard has-post-thumbnail hentry category-community category-escondido category-media category-restaurants category-restaurants-food tag-champions-family-restaurant tag-dan-weisman tag-escondido-restaurants tag-reality-tv tag-restaurant-impossible tag-robert-irvine tag-rosies-cafe tag-the-food-network tag-tv">
	<div class="content-thumb content-grid-thumb"><a href="https://www.escondidograpevine.com/2020/05/23/rosies-cafe-back-on-food-network-thursday/" title="Rosie&#8217;s Cafe back on Food Network Thursday"><img width="180" height="101" src="https://i2.wp.com/www.escondidograpevine.com/wp-content/uploads/2020/05/roies-and-food-network-2.jpeg?resize=180%2C101&amp;ssl=1" class="attachment-content-grid size-content-grid wp-post-image" alt="" loading="lazy" srcset="https://i2.wp.com/www.escondidograpevine.com/wp-content/uploads/2020/05/roies-and-food-network-2.jpeg?resize=777%2C437&amp;ssl=1 777w, https://i2.wp.com/www.escondidograpevine.com/wp-content/uploads/2020/05/roies-and-food-network-2.jpeg?resize=180%2C101&amp;ssl=1 180w, https://i2.wp.com/www.escondidograpevine.com/wp-content/uploads/2020/05/roies-and-food-network-2.jpeg?resize=260%2C146&amp;ssl=1 260w, https://i2.wp.com/www.escondidograpevine.com/wp-content/uploads/2020/05/roies-and-food-network-2.jpeg?resize=373%2C210&amp;ssl=1 373w, https://i2.wp.com/www.escondidograpevine.com/wp-content/uploads/2020/05/roies-and-food-network-2.jpeg?resize=120%2C67&amp;ssl=1 120w, https://i2.wp.com/www.escondidograpevine.com/wp-content/uploads/2020/05/roies-and-food-network-2.jpeg?zoom=3&amp;resize=180%2C101&amp;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" /></a></div>
			<p class="entry-meta"><span><a href="https://www.escondidograpevine.com/category/community/" rel="category tag">Community</a>, <a href="https://www.escondidograpevine.com/category/escondido/" rel="category tag">Escondido</a>, <a href="https://www.escondidograpevine.com/category/media/" rel="category tag">Media</a>, <a href="https://www.escondidograpevine.com/category/restaurants/" rel="category tag">Restaurants</a>, <a href="https://www.escondidograpevine.com/category/food/restaurants-food/" rel="category tag">Restaurants</a></span></p>
		<h3 class="content-grid-title"><a href="https://www.escondidograpevine.com/2020/05/23/rosies-cafe-back-on-food-network-thursday/" title="Rosie&#8217;s Cafe back on Food Network Thursday" rel="bookmark">Rosie&#8217;s Cafe back on Food Network Thursday</a></h3>
</article>
<hr class="mh-separator content-grid-separator"><article class="mh-col mh-1-4 content-grid post-17464 post type-post status-publish format-standard has-post-thumbnail hentry category-escondido category-featured category-food category-grand-avenue category-restaurants category-restaurants-food tag-dan-weisman tag-escondido-restaurants tag-food-blog tag-food-network tag-restaurant-impossible tag-restaurant-makeover-shows tag-robert-irvine tag-rosie-cafe">
	<div class="content-thumb content-grid-thumb"><a href="https://www.escondidograpevine.com/2019/07/22/food-network-say-it-aint-so-rosies-cafe/" title="Food Network: Say it ain&#8217;t so, Rosie&#8217;s Cafe"><img width="180" height="101" src="https://i2.wp.com/www.escondidograpevine.com/wp-content/uploads/2019/04/D4ozYPJWsAEpeoL.jpg-large.jpeg?resize=180%2C101&amp;ssl=1" class="attachment-content-grid size-content-grid wp-post-image" alt="" loading="lazy" srcset="https://i2.wp.com/www.escondidograpevine.com/wp-content/uploads/2019/04/D4ozYPJWsAEpeoL.jpg-large.jpeg?resize=777%2C437&amp;ssl=1 777w, https://i2.wp.com/www.escondidograpevine.com/wp-content/uploads/2019/04/D4ozYPJWsAEpeoL.jpg-large.jpeg?resize=180%2C101&amp;ssl=1 180w, https://i2.wp.com/www.escondidograpevine.com/wp-content/uploads/2019/04/D4ozYPJWsAEpeoL.jpg-large.jpeg?resize=260%2C146&amp;ssl=1 260w, https://i2.wp.com/www.escondidograpevine.com/wp-content/uploads/2019/04/D4ozYPJWsAEpeoL.jpg-large.jpeg?resize=373%2C210&amp;ssl=1 373w, https://i2.wp.com/www.escondidograpevine.com/wp-content/uploads/2019/04/D4ozYPJWsAEpeoL.jpg-large.jpeg?resize=120%2C67&amp;ssl=1 120w, https://i2.wp.com/www.escondidograpevine.com/wp-content/uploads/2019/04/D4ozYPJWsAEpeoL.jpg-large.jpeg?zoom=3&amp;resize=180%2C101&amp;ssl=1 540w" sizes="(max-width: 180px) 100vw, 180px" /></a></div>
			<p class="entry-meta"><span><a href="https://www.escondidograpevine.com/category/escondido/" rel="category tag">Escondido</a>, <a href="https://www.escondidograpevine.com/category/featured/" rel="category tag">Featured</a>, <a href="https://www.escondidograpevine.com/category/food/" rel="category tag">Food</a>, <a href="https://www.escondidograpevine.com/category/escondido/grand-avenue/" rel="category tag">Grand Avenue</a>, <a href="https://www.escondidograpevine.com/category/restaurants/" rel="category tag">Restaurants</a>, <a href="https://www.escondidograpevine.com/category/food/restaurants-food/" rel="category tag">Restaurants</a></span></p>
		<h3 class="content-grid-title"><a href="https://www.escondidograpevine.com/2019/07/22/food-network-say-it-aint-so-rosies-cafe/" title="Food Network: Say it ain&#8217;t so, Rosie&#8217;s Cafe" rel="bookmark">Food Network: Say it ain&#8217;t so, Rosie&#8217;s Cafe</a></h3>
</article>
<hr class="mh-separator content-grid-separator">		</div><div class="comments-wrap">
<h4 class="comment-section-title"><span class="comment-count">Be the first to comment</span> <span class="comment-count-more">on "Justice for Rosie&#8217;s: Hit-run suspect arrested"</span></h4>
</div>
	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2021/01/12/justice-for-rosies-hit-run-suspect-arrested/#respond" style="display:none;">Cancel reply</a></small></h3><p class="must-log-in">You must be <a href="https://www.escondidograpevine.com/wp-login.php?redirect_to=https%3A%2F%2Fwww.escondidograpevine.com%2F2021%2F01%2F12%2Fjustice-for-rosies-hit-run-suspect-arrested%2F">logged in</a> to post a comment.</p>	</div><!-- #respond -->
		<script type="text/javascript">
        jQuery( document ).ready( function( $ ) {
            $( '.comment-form, #registerform' ).append( '<input type="hidden" name="js-spam-prevention" value="cc26893098d6495ae8fcde3feff3d3e6"/>' );
        } );
	</script>
		</div>
	<aside class="mh-sidebar">
	<div class="sb-widget clearfix"><h4 class="widget-title"><span>Weddings, parties, corporate events?</span></h4><div style="width: 310px" class="wp-caption alignnone"><img width="300" height="196" src="https://i0.wp.com/www.escondidograpevine.com/wp-content/uploads/2015/09/Bheau-View3.jpg?fit=300%2C196&amp;ssl=1" class="image wp-image-93  attachment-medium size-medium" alt="" loading="lazy" style="max-width: 100%; height: auto;" srcset="https://i0.wp.com/www.escondidograpevine.com/wp-content/uploads/2015/09/Bheau-View3.jpg?w=840&amp;ssl=1 840w, https://i0.wp.com/www.escondidograpevine.com/wp-content/uploads/2015/09/Bheau-View3.jpg?resize=300%2C196&amp;ssl=1 300w" sizes="(max-width: 300px) 100vw, 300px" /><p class="wp-caption-text">Once called home by one of San Diego's prominent families; a truly one-of-a-kind Rancho Santa Fe Estate is available for events of all shapes and sizes. Hollywood greats like John Wayne, Betty Davis, Bing Crosby and Rex Harrison once wined, dined, enjoyed riding horseback from this luxurious estate directly to the beach. The Estate is a celebrity in its own right. One's dreams, imagination can definitely run wild with no fear of running out of canvas as the estate sits on an enormous 5 1/2 picturesque acres. Want to know more about throwing your dream event there.
Contact Shera Sandwell. Phone: (760) 877-1055 or (858) 367-3693
Email: bheauviewranchevents@gmail.com</p></div></div><div class="sb-widget clearfix"><h4 class="widget-title"><span>Sponsored Content at The Grapevine</span></h4><div style="width: 310px" class="wp-caption alignnone"><a href="https://www.escondidograpevine.com/category/featured-business-review/"><img width="300" height="239" src="https://i0.wp.com/www.escondidograpevine.com/wp-content/uploads/2016/01/OnlyInEscoCartoons-dragged.jpg?fit=300%2C239&amp;ssl=1" class="image wp-image-3474  attachment-medium size-medium" alt="" loading="lazy" style="max-width: 100%; height: auto;" title="Sponsored Content at The Grapevine" srcset="https://i0.wp.com/www.escondidograpevine.com/wp-content/uploads/2016/01/OnlyInEscoCartoons-dragged.jpg?w=1000&amp;ssl=1 1000w, https://i0.wp.com/www.escondidograpevine.com/wp-content/uploads/2016/01/OnlyInEscoCartoons-dragged.jpg?resize=300%2C239&amp;ssl=1 300w, https://i0.wp.com/www.escondidograpevine.com/wp-content/uploads/2016/01/OnlyInEscoCartoons-dragged.jpg?resize=768%2C613&amp;ssl=1 768w" sizes="(max-width: 300px) 100vw, 300px" /></a><p class="wp-caption-text">You're engaged at The Grapevine -- you're reading this, correct -- and enjoy the varied and interesting stories especially created for the North San Diego County community. And you have a product, service, company or whatever to publicize. We can help you if you want to help us. We offer 500-to-700 word stories with optional photo display that runs in our new featured content section. Stories run forever on the site with the latest stories at top of the section. Cost is $300 to $750 depending on the feature. It’s a great way to get out the word about you while helping us cover the community in the rich way it deserves. We also are open to other custom arrangements. Email us at escondidograpevine@gmail.com and we’ll work it out.</p></div></div><div class="sb-widget clearfix"><h4 class="widget-title"><span>Hear It through the Grapevine</span></h4>
            <form action="#" method="post" accept-charset="utf-8" id="subscribe-blog-blog_subscription-3">
				                    <div id="subscribe-text"><p>Enter your email address to subscribe and receive notifications of new posts by email.</p>
</div>                    <p id="subscribe-email">
                        <label id="jetpack-subscribe-label"
                               class="screen-reader-text"
                               for="subscribe-field-blog_subscription-3">
							Email Address                        </label>
                        <input type="email" name="email" required="required"
                        			                                                value=""
                            id="subscribe-field-blog_subscription-3"
                            placeholder="Email Address"
                        />
                    </p>

                    <p id="subscribe-submit">
                        <input type="hidden" name="action" value="subscribe"/>
                        <input type="hidden" name="source" value="https://www.escondidograpevine.com/2021/01/12/justice-for-rosies-hit-run-suspect-arrested/"/>
                        <input type="hidden" name="sub-type" value="widget"/>
                        <input type="hidden" name="redirect_fragment" value="blog_subscription-3"/>
						                        <button type="submit"
	                        		                    	                        name="jetpack_subscriptions_widget"
	                    >
	                        Subscribe                        </button>
                    </p>
				            </form>
		
</div><div class="sb-widget clearfix"><div style="width:100%;" class="wp-video"><!--[if lt IE 9]><script>document.createElement('video');</script><![endif]-->
<video class="wp-video-shortcode" id="video-23757-1" preload="metadata" controls="controls"><source type="video/youtube" src="https://youtu.be/fXi4w6qSQbM?_=1" /><a href="https://youtu.be/fXi4w6qSQbM">https://youtu.be/fXi4w6qSQbM</a></video></div></div><div class="sb-widget clearfix"><div style="width:100%;" class="wp-video"><video class="wp-video-shortcode" id="video-23757-2" preload="metadata" controls="controls"><source type="video/youtube" src="https://youtu.be/StVyKJBZyvA?_=2" /><a href="https://youtu.be/StVyKJBZyvA">https://youtu.be/StVyKJBZyvA</a></video></div></div><div class="sb-widget clearfix"><h4 class="widget-title"><span><a href="https://www.paypal.com/donate/?token=uyMiiUZxV6hLGsji-a7UvmSp8wkYzlvrO95CrkLn8jSAW1buxcihKWlFZbcPhqnYupNW8m&#038;country.x=US&#038;locale.x=US" class="widget-title-link">Donate to The Escondido Grapevine</a></span></h4>        <div class="mh-cp-widget clearfix"> 					<article class="cp-wrap cp-large clearfix">
						<div class="cp-thumb-xl"><a href="https://www.escondidograpevine.com/donate-to-the-escondido-grapevine/" title="Donate to The Escondido Grapevine"><img width="300" height="200" src="https://i2.wp.com/www.escondidograpevine.com/wp-content/uploads/2017/03/phpThumb_generated_thumbnail.jpeg?resize=300%2C200&amp;ssl=1" class="attachment-cp-thumb-xl size-cp-thumb-xl wp-post-image" alt="" loading="lazy" /></a></div>
						<h3 class="cp-title-xl"><a href="https://www.escondidograpevine.com/donate-to-the-escondido-grapevine/" title="Donate to The Escondido Grapevine" rel="bookmark">Donate to The Escondido Grapevine</a></h3>
						<div class="cp-excerpt-xl">
							<p>The Escondido Grapevine has provided factual, informative and interesting information and news for five years. It has been our pleasure and civic duty to do this, especially considering the status of North County as a news desert given the demise of The North County Times and low coverage priority of regional corporate, for-profit media. We have provided this service free of charge and never asked&#8230;</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-15268" class="share-facebook sd-button share-icon no-text" href="https://www.escondidograpevine.com/donate-to-the-escondido-grapevine/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon no-text" href="https://www.escondidograpevine.com/donate-to-the-escondido-grapevine/?share=reddit" target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-15268" class="share-linkedin sd-button share-icon no-text" href="https://www.escondidograpevine.com/donate-to-the-escondido-grapevine/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-15268" class="share-pinterest sd-button share-icon no-text" href="https://www.escondidograpevine.com/donate-to-the-escondido-grapevine/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-15268" class="share-twitter sd-button share-icon no-text" href="https://www.escondidograpevine.com/donate-to-the-escondido-grapevine/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button share-icon no-text" href="https://www.escondidograpevine.com/donate-to-the-escondido-grapevine/?share=email" target="_blank" title="Click to email this to a friend"><span></span><span class="sharing-screen-reader-text">Click to email this to a friend (Opens in new window)</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button share-icon no-text" href="https://www.escondidograpevine.com/donate-to-the-escondido-grapevine/#print" target="_blank" title="Click to print"><span></span><span class="sharing-screen-reader-text">Click to print (Opens in new window)</span></a></li><li><a href="#" class="sharing-anchor sd-button share-more"><span>More</span></a></li><li class="share-end"></li></ul><div class="sharing-hidden"><div class="inner" style="display: none;"><ul><li class="share-tumblr"><a rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button share-icon no-text" href="https://www.escondidograpevine.com/donate-to-the-escondido-grapevine/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span></span><span class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li class="share-pocket"><a rel="nofollow noopener noreferrer" data-shared="" class="share-pocket sd-button share-icon no-text" href="https://www.escondidograpevine.com/donate-to-the-escondido-grapevine/?share=pocket" target="_blank" title="Click to share on Pocket"><span></span><span class="sharing-screen-reader-text">Click to share on Pocket (Opens in new window)</span></a></li><li class="share-end"></li><li class="share-telegram"><a rel="nofollow noopener noreferrer" data-shared="" class="share-telegram sd-button share-icon no-text" href="https://www.escondidograpevine.com/donate-to-the-escondido-grapevine/?share=telegram" target="_blank" title="Click to share on Telegram"><span></span><span class="sharing-screen-reader-text">Click to share on Telegram (Opens in new window)</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon no-text" href="https://www.escondidograpevine.com/donate-to-the-escondido-grapevine/?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp"><span></span><span class="sharing-screen-reader-text">Click to share on WhatsApp (Opens in new window)</span></a></li><li class="share-end"></li><li class="share-skype"><a rel="nofollow noopener noreferrer" data-shared="sharing-skype-15268" class="share-skype sd-button share-icon no-text" href="https://www.escondidograpevine.com/donate-to-the-escondido-grapevine/?share=skype" target="_blank" title="Click to share on Skype"><span></span><span class="sharing-screen-reader-text">Click to share on Skype (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div></div></div>										<a class="button" href="https://www.escondidograpevine.com/donate-to-the-escondido-grapevine/">
				<span>Click Here or title to read more</span>
			</a>						</div>
					</article>
					<hr class="mh-separator">        </div></div><div class="sb-widget clearfix"><h4 class="widget-title"><span><a href="https://www.facebook.com/TheEscondidoGrapevine">Escondido Grapevine Gets Social</a></span></h4>		<div id="fb-root"></div>
		<div class="fb-page" data-href="https://www.facebook.com/TheEscondidoGrapevine" data-width="340"  data-height="580" data-hide-cover="false" data-show-facepile="true" data-tabs="timeline" data-hide-cta="false" data-small-header="true">
		<div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/TheEscondidoGrapevine"><a href="https://www.facebook.com/TheEscondidoGrapevine">Escondido Grapevine Gets Social</a></blockquote></div>
		</div>
		</div><div class="sb-widget clearfix"><h4 class="widget-title"><span>Making of Happy Escondido</span></h4><div style="width:100%;" class="wp-video"><video class="wp-video-shortcode" id="video-23757-3" preload="metadata" controls="controls"><source type="video/youtube" src="https://youtu.be/SSLVOfyc5WM?_=3" /><a href="https://youtu.be/SSLVOfyc5WM">https://youtu.be/SSLVOfyc5WM</a></video></div></div><div class="sb-widget clearfix"><h4 class="widget-title"><span>Blog Stats</span></h4><ul><li>1,283,312 hits</li></ul></div><div class="sb-widget clearfix"><h4 class="widget-title"><span>Traveling Mel does Escondido</span></h4><div style="width:100%;" class="wp-video"><video class="wp-video-shortcode" id="video-23757-4" preload="metadata" controls="controls"><source type="video/youtube" src="https://youtu.be/TsJVRnRyTIM?_=4" /><a href="https://youtu.be/TsJVRnRyTIM">https://youtu.be/TsJVRnRyTIM</a></video></div></div><div class="sb-widget clearfix"><h4 class="widget-title"><span>Popular Posts</span></h4>		<ul class="mh-rp-widget widget-list">				<li class="rp-widget-item"><a href="https://www.escondidograpevine.com/2021/01/12/justice-for-rosies-hit-run-suspect-arrested/" title="Justice for Rosie&#8217;s: Hit-run suspect arrested" rel="bookmark">Justice for Rosie&#8217;s: Hit-run suspect arrested</a></li>				<li class="rp-widget-item"><a href="https://www.escondidograpevine.com/2021/01/07/illegitimate-carpetbagger-issa-couldnt-have-won-the-50th-cong-district-we-must-re-vote/" title="Illegitimate carpetbagger Issa couldn&#8217;t have won the 50th Cong. District. We must re-vote." rel="bookmark">Illegitimate carpetbagger Issa couldn&#8217;t have won the 50th Cong. District. We must re-vote.</a></li>				<li class="rp-widget-item"><a href="https://www.escondidograpevine.com/2021/01/07/covid-19-vaccine-distribution-in-california/" title="COVID-19 vaccine distribution in California" rel="bookmark">COVID-19 vaccine distribution in California</a></li>				<li class="rp-widget-item"><a href="https://www.escondidograpevine.com/2021/01/06/battered-california-gop-struggles-to-survive/" title="Battered, California GOP struggles to survive" rel="bookmark">Battered, California GOP struggles to survive</a></li>				<li class="rp-widget-item"><a href="https://www.escondidograpevine.com/2021/01/04/mare-waldron-is-days-late-and-dollars-short/" title="Marie Waldron is days late and dollars short" rel="bookmark">Marie Waldron is days late and dollars short</a></li>		</ul></div><div class="sb-widget clearfix"><h4 class="widget-title"><span>Check it out</span></h4><form action="https://www.escondidograpevine.com" method="get"><label class="screen-reader-text" for="cat">Check it out</label><select  name='cat' id='cat' class='postform' >
	<option value='-1'>Select Category</option>
	<option class="level-0" value="340">Advertise&nbsp;&nbsp;(11)</option>
	<option class="level-0" value="791">Animals and pets&nbsp;&nbsp;(48)</option>
	<option class="level-0" value="2256">Bonsall&nbsp;&nbsp;(20)</option>
	<option class="level-0" value="158">Business&nbsp;&nbsp;(181)</option>
	<option class="level-1" value="175">&nbsp;&nbsp;&nbsp;Agriculture&nbsp;&nbsp;(73)</option>
	<option class="level-1" value="1085">&nbsp;&nbsp;&nbsp;Biotech/Tech&nbsp;&nbsp;(13)</option>
	<option class="level-1" value="5708">&nbsp;&nbsp;&nbsp;Consumer News&nbsp;&nbsp;(42)</option>
	<option class="level-1" value="518">&nbsp;&nbsp;&nbsp;Real Estate&nbsp;&nbsp;(10)</option>
	<option class="level-1" value="964">&nbsp;&nbsp;&nbsp;Retail&nbsp;&nbsp;(11)</option>
	<option class="level-0" value="5837">California&nbsp;&nbsp;(108)</option>
	<option class="level-1" value="7824">&nbsp;&nbsp;&nbsp;Imperial County&nbsp;&nbsp;(3)</option>
	<option class="level-1" value="5868">&nbsp;&nbsp;&nbsp;Riverside County&nbsp;&nbsp;(38)</option>
	<option class="level-0" value="1014">Community&nbsp;&nbsp;(83)</option>
	<option class="level-1" value="2333">&nbsp;&nbsp;&nbsp;Library&nbsp;&nbsp;(10)</option>
	<option class="level-0" value="7476">Coronavirus&nbsp;&nbsp;(58)</option>
	<option class="level-0" value="6081">Dean Weissmann presents&nbsp;&nbsp;(10)</option>
	<option class="level-0" value="7792">Del Mar/Solana Beach/Encinitas&nbsp;&nbsp;(4)</option>
	<option class="level-0" value="7825">East County&nbsp;&nbsp;(5)</option>
	<option class="level-0" value="83">Education&nbsp;&nbsp;(108)</option>
	<option class="level-0" value="95">Entertainment/Arts&nbsp;&nbsp;(124)</option>
	<option class="level-1" value="78">&nbsp;&nbsp;&nbsp;Arts&nbsp;&nbsp;(42)</option>
	<option class="level-1" value="925">&nbsp;&nbsp;&nbsp;Books&nbsp;&nbsp;(22)</option>
	<option class="level-1" value="413">&nbsp;&nbsp;&nbsp;Comics&nbsp;&nbsp;(8)</option>
	<option class="level-1" value="77">&nbsp;&nbsp;&nbsp;Entertainment&nbsp;&nbsp;(34)</option>
	<option class="level-1" value="2073">&nbsp;&nbsp;&nbsp;Film&nbsp;&nbsp;(7)</option>
	<option class="level-1" value="79">&nbsp;&nbsp;&nbsp;Music&nbsp;&nbsp;(30)</option>
	<option class="level-1" value="147">&nbsp;&nbsp;&nbsp;Theater&nbsp;&nbsp;(26)</option>
	<option class="level-0" value="22">Escondido&nbsp;&nbsp;(204)</option>
	<option class="level-1" value="490">&nbsp;&nbsp;&nbsp;Grand Avenue&nbsp;&nbsp;(22)</option>
	<option class="level-0" value="1308">Escondido City Government&nbsp;&nbsp;(40)</option>
	<option class="level-0" value="7937">Fallbrook&nbsp;&nbsp;(3)</option>
	<option class="level-0" value="4033">Featured&nbsp;&nbsp;(74)</option>
	<option class="level-0" value="185">Featured Business Review&nbsp;&nbsp;(16)</option>
	<option class="level-0" value="7785">Featured Content&nbsp;&nbsp;(1)</option>
	<option class="level-0" value="1356">Financial&nbsp;&nbsp;(9)</option>
	<option class="level-0" value="81">Food&nbsp;&nbsp;(95)</option>
	<option class="level-1" value="540">&nbsp;&nbsp;&nbsp;Healthy Eating&nbsp;&nbsp;(19)</option>
	<option class="level-1" value="469">&nbsp;&nbsp;&nbsp;Restaurants&nbsp;&nbsp;(47)</option>
	<option class="level-1" value="3834">&nbsp;&nbsp;&nbsp;Wine and Beer&nbsp;&nbsp;(17)</option>
	<option class="level-0" value="65">Grapevine Investigation&nbsp;&nbsp;(10)</option>
	<option class="level-0" value="221">History&nbsp;&nbsp;(54)</option>
	<option class="level-0" value="571">Homelessness&nbsp;&nbsp;(16)</option>
	<option class="level-0" value="2055">Immigration&nbsp;&nbsp;(32)</option>
	<option class="level-0" value="4064">Lifestyle&nbsp;&nbsp;(56)</option>
	<option class="level-1" value="4065">&nbsp;&nbsp;&nbsp;Business&nbsp;&nbsp;(11)</option>
	<option class="level-1" value="4066">&nbsp;&nbsp;&nbsp;Health &amp; Fitness&nbsp;&nbsp;(40)</option>
	<option class="level-0" value="102">Lifestyle/Society&nbsp;&nbsp;(118)</option>
	<option class="level-1" value="82">&nbsp;&nbsp;&nbsp;Health&nbsp;&nbsp;(82)</option>
	<option class="level-1" value="109">&nbsp;&nbsp;&nbsp;Home &amp; Garden&nbsp;&nbsp;(9)</option>
	<option class="level-1" value="181">&nbsp;&nbsp;&nbsp;Interior Design&nbsp;&nbsp;(8)</option>
	<option class="level-1" value="541">&nbsp;&nbsp;&nbsp;Lifestyle&nbsp;&nbsp;(26)</option>
	<option class="level-1" value="542">&nbsp;&nbsp;&nbsp;Society&nbsp;&nbsp;(15)</option>
	<option class="level-0" value="6360">Media&nbsp;&nbsp;(34)</option>
	<option class="level-0" value="890">Metaphysical&nbsp;&nbsp;(7)</option>
	<option class="level-0" value="940">Military&nbsp;&nbsp;(22)</option>
	<option class="level-0" value="93">News&nbsp;&nbsp;(103)</option>
	<option class="level-1" value="94">&nbsp;&nbsp;&nbsp;Breaking News&nbsp;&nbsp;(93)</option>
	<option class="level-0" value="24">North County&nbsp;&nbsp;(141)</option>
	<option class="level-0" value="57">Opinion&nbsp;&nbsp;(144)</option>
	<option class="level-1" value="174">&nbsp;&nbsp;&nbsp;Blogs&nbsp;&nbsp;(80)</option>
	<option class="level-1" value="126">&nbsp;&nbsp;&nbsp;Columns/Blogs&nbsp;&nbsp;(80)</option>
	<option class="level-1" value="127">&nbsp;&nbsp;&nbsp;Editorial&nbsp;&nbsp;(30)</option>
	<option class="level-1" value="467">&nbsp;&nbsp;&nbsp;Public Policy&nbsp;&nbsp;(49)</option>
	<option class="level-0" value="267">Police/Fire&nbsp;&nbsp;(134)</option>
	<option class="level-1" value="339">&nbsp;&nbsp;&nbsp;Courts/Law&nbsp;&nbsp;(38)</option>
	<option class="level-1" value="75">&nbsp;&nbsp;&nbsp;Fire&nbsp;&nbsp;(24)</option>
	<option class="level-1" value="76">&nbsp;&nbsp;&nbsp;Police&nbsp;&nbsp;(87)</option>
	<option class="level-0" value="58">Politics&nbsp;&nbsp;(211)</option>
	<option class="level-1" value="5958">&nbsp;&nbsp;&nbsp;Darrell Issa investigations&nbsp;&nbsp;(11)</option>
	<option class="level-1" value="5957">&nbsp;&nbsp;&nbsp;Duncan Hunter investigations&nbsp;&nbsp;(48)</option>
	<option class="level-0" value="54">Rancho Santa Fe&nbsp;&nbsp;(51)</option>
	<option class="level-0" value="80">Restaurants&nbsp;&nbsp;(25)</option>
	<option class="level-0" value="25">San Diego&nbsp;&nbsp;(104)</option>
	<option class="level-0" value="21">San Marcos&nbsp;&nbsp;(91)</option>
	<option class="level-0" value="6421">San Marcos City Government&nbsp;&nbsp;(9)</option>
	<option class="level-0" value="124">Sports&nbsp;&nbsp;(86)</option>
	<option class="level-1" value="437">&nbsp;&nbsp;&nbsp;Baseball&nbsp;&nbsp;(28)</option>
	<option class="level-1" value="3325">&nbsp;&nbsp;&nbsp;Boxing&nbsp;&nbsp;(4)</option>
	<option class="level-1" value="1532">&nbsp;&nbsp;&nbsp;Fishing&nbsp;&nbsp;(7)</option>
	<option class="level-1" value="621">&nbsp;&nbsp;&nbsp;Football&nbsp;&nbsp;(11)</option>
	<option class="level-1" value="516">&nbsp;&nbsp;&nbsp;Golf&nbsp;&nbsp;(7)</option>
	<option class="level-1" value="5125">&nbsp;&nbsp;&nbsp;Horse racing&nbsp;&nbsp;(6)</option>
	<option class="level-0" value="125">Surprising and Strange&nbsp;&nbsp;(48)</option>
	<option class="level-0" value="525">The Grapevine&nbsp;&nbsp;(17)</option>
	<option class="level-0" value="92">The World&nbsp;&nbsp;(109)</option>
	<option class="level-0" value="40">Tourism&nbsp;&nbsp;(49)</option>
	<option class="level-0" value="3421">Traffic&nbsp;&nbsp;(17)</option>
	<option class="level-0" value="1577">Transportation&nbsp;&nbsp;(36)</option>
	<option class="level-0" value="70">Travel&nbsp;&nbsp;(45)</option>
	<option class="level-0" value="23">Valley Center&nbsp;&nbsp;(96)</option>
	<option class="level-0" value="4069">Video&nbsp;&nbsp;(4)</option>
	<option class="level-0" value="5348">Vista&nbsp;&nbsp;(31)</option>
	<option class="level-0" value="1801">Weather&nbsp;&nbsp;(30)</option>
</select>
</form>
<script type="text/javascript">
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "cat" );
	function onCatChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value > 0 ) {
			dropdown.parentNode.submit();
		}
	}
	dropdown.onchange = onCatChange;
})();
/* ]]> */
</script>

			</div><div class="sb-widget clearfix"><h4 class="widget-title"><span>Dashni Morad I Am (Open Your Eyes)</span></h4><div style="width:100%;" class="wp-video"><video class="wp-video-shortcode" id="video-23757-5" preload="metadata" controls="controls"><source type="video/youtube" src="https://youtu.be/dwufQD6O3nc?_=5" /><a href="https://youtu.be/dwufQD6O3nc">https://youtu.be/dwufQD6O3nc</a></video></div></div><div class="sb-widget clearfix"><h4 class="widget-title"><span>Family of the Year &#8212; &#8216;Hero&#8217;</span></h4><div style="width:100%;" class="wp-video"><video class="wp-video-shortcode" id="video-23757-6" preload="metadata" controls="controls"><source type="video/youtube" src="https://youtu.be/mYFaghHyMKc?_=6" /><a href="https://youtu.be/mYFaghHyMKc">https://youtu.be/mYFaghHyMKc</a></video></div></div><div class="sb-widget clearfix"><h4 class="widget-title"><span>Merle Haggard does Blaze Foley</span></h4><div style="width:100%;" class="wp-video"><video class="wp-video-shortcode" id="video-23757-7" preload="metadata" controls="controls"><source type="video/youtube" src="https://youtu.be/24cqKEjAALg?_=7" /><a href="https://youtu.be/24cqKEjAALg">https://youtu.be/24cqKEjAALg</a></video></div></div><div class="sb-widget clearfix"><h4 class="widget-title"><span>Hear it through the Grapevine</span></h4>
            <form action="#" method="post" accept-charset="utf-8" id="subscribe-blog-blog_subscription-4">
				                    <div id="subscribe-text"><p>Enter your email address to subscribe and receive notifications of new posts by email.</p>
</div>                    <p id="subscribe-email">
                        <label id="jetpack-subscribe-label"
                               class="screen-reader-text"
                               for="subscribe-field-blog_subscription-4">
							Email Address                        </label>
                        <input type="email" name="email" required="required"
                        			                                                value=""
                            id="subscribe-field-blog_subscription-4"
                            placeholder="Email Address"
                        />
                    </p>

                    <p id="subscribe-submit">
                        <input type="hidden" name="action" value="subscribe"/>
                        <input type="hidden" name="source" value="https://www.escondidograpevine.com/2021/01/12/justice-for-rosies-hit-run-suspect-arrested/"/>
                        <input type="hidden" name="sub-type" value="widget"/>
                        <input type="hidden" name="redirect_fragment" value="blog_subscription-4"/>
						                        <button type="submit"
	                        		                    	                        name="jetpack_subscriptions_widget"
	                    >
	                        Subscribe                        </button>
                    </p>
				            </form>
		
</div><div class="sb-widget clearfix"><h4 class="widget-title"><span><a href="https://www.escondidograpevine.com/category/advertise/" class="widget-title-link">Featured Content</a></span></h4>		<div class="mh-fp-large-widget clearfix"><article class="content-lead post-18369 post type-post status-publish format-standard has-post-thumbnail hentry category-advertise category-community category-entertainment category-entertainmentarts category-featured category-music tag-greg-douglass tag-leon-hendrix tag-missing-persons tag-skylar-peterson-tosic tag-woodstock">
	<div class="content-thumb content-lead-thumb"><a href="https://www.escondidograpevine.com/2019/08/12/woodstocked-celebrates-hippiedom-while-raising-funds-to-locate-missing-persons/" title="Woodstocked celebrates hippiedom while raising funds to locate missing persons"><img width="777" height="437" src="https://i2.wp.com/www.escondidograpevine.com/wp-content/uploads/2019/08/woodstocked-3.jpg?resize=777%2C437&amp;ssl=1" class="attachment-content-single size-content-single wp-post-image" alt="" loading="lazy" srcset="https://i2.wp.com/www.escondidograpevine.com/wp-content/uploads/2019/08/woodstocked-3.jpg?resize=777%2C437&amp;ssl=1 777w, https://i2.wp.com/www.escondidograpevine.com/wp-content/uploads/2019/08/woodstocked-3.jpg?resize=180%2C101&amp;ssl=1 180w, https://i2.wp.com/www.escondidograpevine.com/wp-content/uploads/2019/08/woodstocked-3.jpg?resize=260%2C146&amp;ssl=1 260w, https://i2.wp.com/www.escondidograpevine.com/wp-content/uploads/2019/08/woodstocked-3.jpg?resize=373%2C210&amp;ssl=1 373w, https://i2.wp.com/www.escondidograpevine.com/wp-content/uploads/2019/08/woodstocked-3.jpg?resize=120%2C67&amp;ssl=1 120w" sizes="(max-width: 777px) 100vw, 777px" /></a></div>
	<p class="entry-meta">
<span class="entry-meta-author vcard author">Posted By: <a class="fn" href="https://www.escondidograpevine.com/author/the-grapevine/">The Grapevine</a></span>
<span class="entry-meta-date updated">August 12, 2019</span>
</p>
	<h3 class="content-lead-title"><a href="https://www.escondidograpevine.com/2019/08/12/woodstocked-celebrates-hippiedom-while-raising-funds-to-locate-missing-persons/" title="Woodstocked celebrates hippiedom while raising funds to locate missing persons" rel="bookmark">Woodstocked celebrates hippiedom while raising funds to locate missing persons</a></h3>
	<div class="content-lead-excerpt">
		<p>Who: Leon Hendrix, Jocko Marcellino, Roni Lee, Greg Douglass, Thomas Alan Connor, and many more&#8230; What: live music “Hippie-fest” featuring celebrity musicians, and some of the BEST local San Diego musicians. Where: Full Circle Saloon, 8528 N. Magnolia Ave. Suite 105, Santee, California 92071. When: 4 p.m. to 10 p.m. Sunday, Aug. 18, 2019. Why: To celebrate and commemorate the 50th Anniversary Of Woodstock and&#8230;</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-18369" class="share-facebook sd-button share-icon no-text" href="https://www.escondidograpevine.com/2019/08/12/woodstocked-celebrates-hippiedom-while-raising-funds-to-locate-missing-persons/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon no-text" href="https://www.escondidograpevine.com/2019/08/12/woodstocked-celebrates-hippiedom-while-raising-funds-to-locate-missing-persons/?share=reddit" target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-18369" class="share-linkedin sd-button share-icon no-text" href="https://www.escondidograpevine.com/2019/08/12/woodstocked-celebrates-hippiedom-while-raising-funds-to-locate-missing-persons/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-18369" class="share-pinterest sd-button share-icon no-text" href="https://www.escondidograpevine.com/2019/08/12/woodstocked-celebrates-hippiedom-while-raising-funds-to-locate-missing-persons/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-18369" class="share-twitter sd-button share-icon no-text" href="https://www.escondidograpevine.com/2019/08/12/woodstocked-celebrates-hippiedom-while-raising-funds-to-locate-missing-persons/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button share-icon no-text" href="https://www.escondidograpevine.com/2019/08/12/woodstocked-celebrates-hippiedom-while-raising-funds-to-locate-missing-persons/?share=email" target="_blank" title="Click to email this to a friend"><span></span><span class="sharing-screen-reader-text">Click to email this to a friend (Opens in new window)</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button share-icon no-text" href="https://www.escondidograpevine.com/2019/08/12/woodstocked-celebrates-hippiedom-while-raising-funds-to-locate-missing-persons/#print" target="_blank" title="Click to print"><span></span><span class="sharing-screen-reader-text">Click to print (Opens in new window)</span></a></li><li><a href="#" class="sharing-anchor sd-button share-more"><span>More</span></a></li><li class="share-end"></li></ul><div class="sharing-hidden"><div class="inner" style="display: none;"><ul><li class="share-tumblr"><a rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button share-icon no-text" href="https://www.escondidograpevine.com/2019/08/12/woodstocked-celebrates-hippiedom-while-raising-funds-to-locate-missing-persons/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span></span><span class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li class="share-pocket"><a rel="nofollow noopener noreferrer" data-shared="" class="share-pocket sd-button share-icon no-text" href="https://www.escondidograpevine.com/2019/08/12/woodstocked-celebrates-hippiedom-while-raising-funds-to-locate-missing-persons/?share=pocket" target="_blank" title="Click to share on Pocket"><span></span><span class="sharing-screen-reader-text">Click to share on Pocket (Opens in new window)</span></a></li><li class="share-end"></li><li class="share-telegram"><a rel="nofollow noopener noreferrer" data-shared="" class="share-telegram sd-button share-icon no-text" href="https://www.escondidograpevine.com/2019/08/12/woodstocked-celebrates-hippiedom-while-raising-funds-to-locate-missing-persons/?share=telegram" target="_blank" title="Click to share on Telegram"><span></span><span class="sharing-screen-reader-text">Click to share on Telegram (Opens in new window)</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon no-text" href="https://www.escondidograpevine.com/2019/08/12/woodstocked-celebrates-hippiedom-while-raising-funds-to-locate-missing-persons/?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp"><span></span><span class="sharing-screen-reader-text">Click to share on WhatsApp (Opens in new window)</span></a></li><li class="share-end"></li><li class="share-skype"><a rel="nofollow noopener noreferrer" data-shared="sharing-skype-18369" class="share-skype sd-button share-icon no-text" href="https://www.escondidograpevine.com/2019/08/12/woodstocked-celebrates-hippiedom-while-raising-funds-to-locate-missing-persons/?share=skype" target="_blank" title="Click to share on Skype"><span></span><span class="sharing-screen-reader-text">Click to share on Skype (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div></div></div>					<a class="button" href="https://www.escondidograpevine.com/2019/08/12/woodstocked-celebrates-hippiedom-while-raising-funds-to-locate-missing-persons/">
				<span>Click Here or title to read more</span>
			</a>	</div>
</article><hr class="mh-separator">
<article class="content-lead post-18164 post type-post status-publish format-standard has-post-thumbnail hentry category-advertise category-community category-editorial category-opinion category-the-grapevine tag-advertising tag-community-news tag-dan-weisman tag-escondido-community tag-lion tag-north-county-san-diego-media tag-online-community-journalism tag-pr-agents tag-the-escondido-grapevine">
	<div class="content-thumb content-lead-thumb"><a href="https://www.escondidograpevine.com/2019/07/23/community-news-for-the-rest-of-us/" title="Community news for the rest of us"><img width="633" height="437" src="https://i0.wp.com/www.escondidograpevine.com/wp-content/uploads/2015/09/1013065_564158063628071_1432895486_n.jpg?resize=633%2C437&amp;ssl=1" class="attachment-content-single size-content-single wp-post-image" alt="" loading="lazy" /></a></div>
	<p class="entry-meta">
<span class="entry-meta-author vcard author">Posted By: <a class="fn" href="https://www.escondidograpevine.com/author/dweisman/">dweisman</a></span>
<span class="entry-meta-date updated">July 23, 2019</span>
</p>
	<h3 class="content-lead-title"><a href="https://www.escondidograpevine.com/2019/07/23/community-news-for-the-rest-of-us/" title="Community news for the rest of us" rel="bookmark">Community news for the rest of us</a></h3>
	<div class="content-lead-excerpt">
		<p>People, but mainly PR agents, send stuff all the time to our e-mail account. Sometimes we publish, many times we don&#8217;t because, you know, that&#8217;s how we roll. When PR agents, known in old-time journo lingo as &#8220;flacks,&#8221; send us material, we send them back our ad rates, which are $100 a month for sidebar ads, $200 a month for banner ads below the top&#8230;</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-18164" class="share-facebook sd-button share-icon no-text" href="https://www.escondidograpevine.com/2019/07/23/community-news-for-the-rest-of-us/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon no-text" href="https://www.escondidograpevine.com/2019/07/23/community-news-for-the-rest-of-us/?share=reddit" target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-18164" class="share-linkedin sd-button share-icon no-text" href="https://www.escondidograpevine.com/2019/07/23/community-news-for-the-rest-of-us/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-18164" class="share-pinterest sd-button share-icon no-text" href="https://www.escondidograpevine.com/2019/07/23/community-news-for-the-rest-of-us/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-18164" class="share-twitter sd-button share-icon no-text" href="https://www.escondidograpevine.com/2019/07/23/community-news-for-the-rest-of-us/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button share-icon no-text" href="https://www.escondidograpevine.com/2019/07/23/community-news-for-the-rest-of-us/?share=email" target="_blank" title="Click to email this to a friend"><span></span><span class="sharing-screen-reader-text">Click to email this to a friend (Opens in new window)</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button share-icon no-text" href="https://www.escondidograpevine.com/2019/07/23/community-news-for-the-rest-of-us/#print" target="_blank" title="Click to print"><span></span><span class="sharing-screen-reader-text">Click to print (Opens in new window)</span></a></li><li><a href="#" class="sharing-anchor sd-button share-more"><span>More</span></a></li><li class="share-end"></li></ul><div class="sharing-hidden"><div class="inner" style="display: none;"><ul><li class="share-tumblr"><a rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button share-icon no-text" href="https://www.escondidograpevine.com/2019/07/23/community-news-for-the-rest-of-us/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span></span><span class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li class="share-pocket"><a rel="nofollow noopener noreferrer" data-shared="" class="share-pocket sd-button share-icon no-text" href="https://www.escondidograpevine.com/2019/07/23/community-news-for-the-rest-of-us/?share=pocket" target="_blank" title="Click to share on Pocket"><span></span><span class="sharing-screen-reader-text">Click to share on Pocket (Opens in new window)</span></a></li><li class="share-end"></li><li class="share-telegram"><a rel="nofollow noopener noreferrer" data-shared="" class="share-telegram sd-button share-icon no-text" href="https://www.escondidograpevine.com/2019/07/23/community-news-for-the-rest-of-us/?share=telegram" target="_blank" title="Click to share on Telegram"><span></span><span class="sharing-screen-reader-text">Click to share on Telegram (Opens in new window)</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon no-text" href="https://www.escondidograpevine.com/2019/07/23/community-news-for-the-rest-of-us/?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp"><span></span><span class="sharing-screen-reader-text">Click to share on WhatsApp (Opens in new window)</span></a></li><li class="share-end"></li><li class="share-skype"><a rel="nofollow noopener noreferrer" data-shared="sharing-skype-18164" class="share-skype sd-button share-icon no-text" href="https://www.escondidograpevine.com/2019/07/23/community-news-for-the-rest-of-us/?share=skype" target="_blank" title="Click to share on Skype"><span></span><span class="sharing-screen-reader-text">Click to share on Skype (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div></div></div>					<a class="button" href="https://www.escondidograpevine.com/2019/07/23/community-news-for-the-rest-of-us/">
				<span>Click Here or title to read more</span>
			</a>	</div>
</article><hr class="mh-separator">
<article class="content-lead post-3621 post type-post status-publish format-standard has-post-thumbnail hentry category-advertise category-business category-retail tag-black-hole tag-dna tag-escondido-business tag-escondido-retail tag-escondido-sales tag-home-decor-imports tag-home-furnishings tag-north-county-retail tag-tailor-shop">
	<div class="content-thumb content-lead-thumb"><a href="https://www.escondidograpevine.com/2018/03/06/home-decor-imports-where-astrophysics-meets-accent-pieces/" title="Home Decor Imports where astrophysics meets accent pieces"><img width="777" height="437" src="https://i1.wp.com/www.escondidograpevine.com/wp-content/uploads/2016/01/home-decor1.jpg?resize=777%2C437&amp;ssl=1" class="attachment-content-single size-content-single wp-post-image" alt="" loading="lazy" srcset="https://i1.wp.com/www.escondidograpevine.com/wp-content/uploads/2016/01/home-decor1.jpg?resize=777%2C437&amp;ssl=1 777w, https://i1.wp.com/www.escondidograpevine.com/wp-content/uploads/2016/01/home-decor1.jpg?resize=180%2C101&amp;ssl=1 180w, https://i1.wp.com/www.escondidograpevine.com/wp-content/uploads/2016/01/home-decor1.jpg?resize=260%2C146&amp;ssl=1 260w, https://i1.wp.com/www.escondidograpevine.com/wp-content/uploads/2016/01/home-decor1.jpg?resize=373%2C210&amp;ssl=1 373w, https://i1.wp.com/www.escondidograpevine.com/wp-content/uploads/2016/01/home-decor1.jpg?resize=120%2C67&amp;ssl=1 120w" sizes="(max-width: 777px) 100vw, 777px" /></a></div>
	<p class="entry-meta">
<span class="entry-meta-author vcard author">Posted By: <a class="fn" href="https://www.escondidograpevine.com/author/dweisman/">dweisman</a></span>
<span class="entry-meta-date updated">March 6, 2018</span>
</p>
	<h3 class="content-lead-title"><a href="https://www.escondidograpevine.com/2018/03/06/home-decor-imports-where-astrophysics-meets-accent-pieces/" title="Home Decor Imports where astrophysics meets accent pieces" rel="bookmark">Home Decor Imports where astrophysics meets accent pieces</a></h3>
	<div class="content-lead-excerpt">
		<p>What: Home Decor Imports winter sale. When: Now through April. Where: 233 E Grand Ave. (760-489-4401). www.HomeDecorImports.com Why: Get 30 to 40 percent off fabulous items, 25 percent of sales goes to non-profit. Say “I heard it through the Grapevine” and receive special consideration; 25 percent of all sales goes to health, wellness and equestrian non-profit. Javad Fardaei scours the universe for clues when it&#8230;</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-3621" class="share-facebook sd-button share-icon no-text" href="https://www.escondidograpevine.com/2018/03/06/home-decor-imports-where-astrophysics-meets-accent-pieces/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon no-text" href="https://www.escondidograpevine.com/2018/03/06/home-decor-imports-where-astrophysics-meets-accent-pieces/?share=reddit" target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-3621" class="share-linkedin sd-button share-icon no-text" href="https://www.escondidograpevine.com/2018/03/06/home-decor-imports-where-astrophysics-meets-accent-pieces/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-3621" class="share-pinterest sd-button share-icon no-text" href="https://www.escondidograpevine.com/2018/03/06/home-decor-imports-where-astrophysics-meets-accent-pieces/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-3621" class="share-twitter sd-button share-icon no-text" href="https://www.escondidograpevine.com/2018/03/06/home-decor-imports-where-astrophysics-meets-accent-pieces/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button share-icon no-text" href="https://www.escondidograpevine.com/2018/03/06/home-decor-imports-where-astrophysics-meets-accent-pieces/?share=email" target="_blank" title="Click to email this to a friend"><span></span><span class="sharing-screen-reader-text">Click to email this to a friend (Opens in new window)</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button share-icon no-text" href="https://www.escondidograpevine.com/2018/03/06/home-decor-imports-where-astrophysics-meets-accent-pieces/#print" target="_blank" title="Click to print"><span></span><span class="sharing-screen-reader-text">Click to print (Opens in new window)</span></a></li><li><a href="#" class="sharing-anchor sd-button share-more"><span>More</span></a></li><li class="share-end"></li></ul><div class="sharing-hidden"><div class="inner" style="display: none;"><ul><li class="share-tumblr"><a rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button share-icon no-text" href="https://www.escondidograpevine.com/2018/03/06/home-decor-imports-where-astrophysics-meets-accent-pieces/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span></span><span class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li class="share-pocket"><a rel="nofollow noopener noreferrer" data-shared="" class="share-pocket sd-button share-icon no-text" href="https://www.escondidograpevine.com/2018/03/06/home-decor-imports-where-astrophysics-meets-accent-pieces/?share=pocket" target="_blank" title="Click to share on Pocket"><span></span><span class="sharing-screen-reader-text">Click to share on Pocket (Opens in new window)</span></a></li><li class="share-end"></li><li class="share-telegram"><a rel="nofollow noopener noreferrer" data-shared="" class="share-telegram sd-button share-icon no-text" href="https://www.escondidograpevine.com/2018/03/06/home-decor-imports-where-astrophysics-meets-accent-pieces/?share=telegram" target="_blank" title="Click to share on Telegram"><span></span><span class="sharing-screen-reader-text">Click to share on Telegram (Opens in new window)</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon no-text" href="https://www.escondidograpevine.com/2018/03/06/home-decor-imports-where-astrophysics-meets-accent-pieces/?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp"><span></span><span class="sharing-screen-reader-text">Click to share on WhatsApp (Opens in new window)</span></a></li><li class="share-end"></li><li class="share-skype"><a rel="nofollow noopener noreferrer" data-shared="sharing-skype-3621" class="share-skype sd-button share-icon no-text" href="https://www.escondidograpevine.com/2018/03/06/home-decor-imports-where-astrophysics-meets-accent-pieces/?share=skype" target="_blank" title="Click to share on Skype"><span></span><span class="sharing-screen-reader-text">Click to share on Skype (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div></div></div>					<a class="button" href="https://www.escondidograpevine.com/2018/03/06/home-decor-imports-where-astrophysics-meets-accent-pieces/">
				<span>Click Here or title to read more</span>
			</a>	</div>
</article><hr class="mh-separator">
<article class="content-lead post-8269 post type-post status-publish format-standard has-post-thumbnail hentry category-advertise category-featured-business-review category-the-grapevine tag-4390 tag-4389 tag-dan-weisman tag-escondido-grapevine tag-independent-journalism tag-lion tag-online-independent-journalism tag-us tag-ut">
	<div class="content-thumb content-lead-thumb"><a href="https://www.escondidograpevine.com/2016/09/05/modest-proposal-support-the-grapevine/" title="Modest proposal: Support The Grapevine"><img width="576" height="437" src="https://i0.wp.com/www.escondidograpevine.com/wp-content/uploads/2016/09/TheGrapvine-copy.jpg?resize=576%2C437&amp;ssl=1" class="attachment-content-single size-content-single wp-post-image" alt="" loading="lazy" /></a></div>
	<p class="entry-meta">
<span class="entry-meta-author vcard author">Posted By: <a class="fn" href="https://www.escondidograpevine.com/author/dweisman/">dweisman</a></span>
<span class="entry-meta-date updated">September 5, 2016</span>
</p>
	<h3 class="content-lead-title"><a href="https://www.escondidograpevine.com/2016/09/05/modest-proposal-support-the-grapevine/" title="Modest proposal: Support The Grapevine" rel="bookmark">Modest proposal: Support The Grapevine</a></h3>
	<div class="content-lead-excerpt">
		<p>The Escondido Grapevine website has proven successful, reaching 500 to 6,000 visitors daily, and gaining national recognition for quality and direction. Now, it’s time to do more, but that takes community sponsorship. Sponsorship ads can be successful on many levels. Sponsors receive maximum and positive community exposure, reaching local residents in the most popular and credible online format available today. Aside from getting out the&#8230;</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-8269" class="share-facebook sd-button share-icon no-text" href="https://www.escondidograpevine.com/2016/09/05/modest-proposal-support-the-grapevine/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon no-text" href="https://www.escondidograpevine.com/2016/09/05/modest-proposal-support-the-grapevine/?share=reddit" target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-8269" class="share-linkedin sd-button share-icon no-text" href="https://www.escondidograpevine.com/2016/09/05/modest-proposal-support-the-grapevine/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-8269" class="share-pinterest sd-button share-icon no-text" href="https://www.escondidograpevine.com/2016/09/05/modest-proposal-support-the-grapevine/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-8269" class="share-twitter sd-button share-icon no-text" href="https://www.escondidograpevine.com/2016/09/05/modest-proposal-support-the-grapevine/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button share-icon no-text" href="https://www.escondidograpevine.com/2016/09/05/modest-proposal-support-the-grapevine/?share=email" target="_blank" title="Click to email this to a friend"><span></span><span class="sharing-screen-reader-text">Click to email this to a friend (Opens in new window)</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button share-icon no-text" href="https://www.escondidograpevine.com/2016/09/05/modest-proposal-support-the-grapevine/#print" target="_blank" title="Click to print"><span></span><span class="sharing-screen-reader-text">Click to print (Opens in new window)</span></a></li><li><a href="#" class="sharing-anchor sd-button share-more"><span>More</span></a></li><li class="share-end"></li></ul><div class="sharing-hidden"><div class="inner" style="display: none;"><ul><li class="share-tumblr"><a rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button share-icon no-text" href="https://www.escondidograpevine.com/2016/09/05/modest-proposal-support-the-grapevine/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span></span><span class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li class="share-pocket"><a rel="nofollow noopener noreferrer" data-shared="" class="share-pocket sd-button share-icon no-text" href="https://www.escondidograpevine.com/2016/09/05/modest-proposal-support-the-grapevine/?share=pocket" target="_blank" title="Click to share on Pocket"><span></span><span class="sharing-screen-reader-text">Click to share on Pocket (Opens in new window)</span></a></li><li class="share-end"></li><li class="share-telegram"><a rel="nofollow noopener noreferrer" data-shared="" class="share-telegram sd-button share-icon no-text" href="https://www.escondidograpevine.com/2016/09/05/modest-proposal-support-the-grapevine/?share=telegram" target="_blank" title="Click to share on Telegram"><span></span><span class="sharing-screen-reader-text">Click to share on Telegram (Opens in new window)</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon no-text" href="https://www.escondidograpevine.com/2016/09/05/modest-proposal-support-the-grapevine/?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp"><span></span><span class="sharing-screen-reader-text">Click to share on WhatsApp (Opens in new window)</span></a></li><li class="share-end"></li><li class="share-skype"><a rel="nofollow noopener noreferrer" data-shared="sharing-skype-8269" class="share-skype sd-button share-icon no-text" href="https://www.escondidograpevine.com/2016/09/05/modest-proposal-support-the-grapevine/?share=skype" target="_blank" title="Click to share on Skype"><span></span><span class="sharing-screen-reader-text">Click to share on Skype (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div></div></div>					<a class="button" href="https://www.escondidograpevine.com/2016/09/05/modest-proposal-support-the-grapevine/">
				<span>Click Here or title to read more</span>
			</a>	</div>
</article><hr class="mh-separator">
<article class="content-lead post-4827 post type-post status-publish format-standard has-post-thumbnail hentry category-advertise tag-escondido tag-escondido-grapevine tag-online-ads tag-online-community-journalism tag-san-diego-advertising tag-san-marcos tag-valley-center">
	<div class="content-thumb content-lead-thumb"><a href="https://www.escondidograpevine.com/2016/03/15/join-these-escondido-grapevine-sponsors/" title="Join these Escondido Grapevine sponsors"><img width="300" height="100" src="https://i2.wp.com/www.escondidograpevine.com/wp-content/uploads/2016/03/escobanner2.png?resize=300%2C100&amp;ssl=1" class="attachment-content-single size-content-single wp-post-image" alt="" loading="lazy" /></a></div>
	<p class="entry-meta">
<span class="entry-meta-author vcard author">Posted By: <a class="fn" href="https://www.escondidograpevine.com/author/the-grapevine/">The Grapevine</a></span>
<span class="entry-meta-date updated">March 15, 2016</span>
</p>
	<h3 class="content-lead-title"><a href="https://www.escondidograpevine.com/2016/03/15/join-these-escondido-grapevine-sponsors/" title="Join these Escondido Grapevine sponsors" rel="bookmark">Join these Escondido Grapevine sponsors</a></h3>
	<div class="content-lead-excerpt">
		<p>Be special. Get out the good word about you and your business. Connect direct with the community. Enjoy special sponsorship and membership opportunities. Email EscondidoGrapevine@gmail.com for more information. Or call (760) 877-1055. JOIN THESE GREAT SPONSORS IN THE ESCONDIDO GRAPEVINE FAMILY: &nbsp; &nbsp; &nbsp;</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-4827" class="share-facebook sd-button share-icon no-text" href="https://www.escondidograpevine.com/2016/03/15/join-these-escondido-grapevine-sponsors/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon no-text" href="https://www.escondidograpevine.com/2016/03/15/join-these-escondido-grapevine-sponsors/?share=reddit" target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-4827" class="share-linkedin sd-button share-icon no-text" href="https://www.escondidograpevine.com/2016/03/15/join-these-escondido-grapevine-sponsors/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-4827" class="share-pinterest sd-button share-icon no-text" href="https://www.escondidograpevine.com/2016/03/15/join-these-escondido-grapevine-sponsors/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-4827" class="share-twitter sd-button share-icon no-text" href="https://www.escondidograpevine.com/2016/03/15/join-these-escondido-grapevine-sponsors/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button share-icon no-text" href="https://www.escondidograpevine.com/2016/03/15/join-these-escondido-grapevine-sponsors/?share=email" target="_blank" title="Click to email this to a friend"><span></span><span class="sharing-screen-reader-text">Click to email this to a friend (Opens in new window)</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button share-icon no-text" href="https://www.escondidograpevine.com/2016/03/15/join-these-escondido-grapevine-sponsors/#print" target="_blank" title="Click to print"><span></span><span class="sharing-screen-reader-text">Click to print (Opens in new window)</span></a></li><li><a href="#" class="sharing-anchor sd-button share-more"><span>More</span></a></li><li class="share-end"></li></ul><div class="sharing-hidden"><div class="inner" style="display: none;"><ul><li class="share-tumblr"><a rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button share-icon no-text" href="https://www.escondidograpevine.com/2016/03/15/join-these-escondido-grapevine-sponsors/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span></span><span class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li class="share-pocket"><a rel="nofollow noopener noreferrer" data-shared="" class="share-pocket sd-button share-icon no-text" href="https://www.escondidograpevine.com/2016/03/15/join-these-escondido-grapevine-sponsors/?share=pocket" target="_blank" title="Click to share on Pocket"><span></span><span class="sharing-screen-reader-text">Click to share on Pocket (Opens in new window)</span></a></li><li class="share-end"></li><li class="share-telegram"><a rel="nofollow noopener noreferrer" data-shared="" class="share-telegram sd-button share-icon no-text" href="https://www.escondidograpevine.com/2016/03/15/join-these-escondido-grapevine-sponsors/?share=telegram" target="_blank" title="Click to share on Telegram"><span></span><span class="sharing-screen-reader-text">Click to share on Telegram (Opens in new window)</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon no-text" href="https://www.escondidograpevine.com/2016/03/15/join-these-escondido-grapevine-sponsors/?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp"><span></span><span class="sharing-screen-reader-text">Click to share on WhatsApp (Opens in new window)</span></a></li><li class="share-end"></li><li class="share-skype"><a rel="nofollow noopener noreferrer" data-shared="sharing-skype-4827" class="share-skype sd-button share-icon no-text" href="https://www.escondidograpevine.com/2016/03/15/join-these-escondido-grapevine-sponsors/?share=skype" target="_blank" title="Click to share on Skype"><span></span><span class="sharing-screen-reader-text">Click to share on Skype (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div></div></div>					<a class="button" href="https://www.escondidograpevine.com/2016/03/15/join-these-escondido-grapevine-sponsors/">
				<span>Click Here or title to read more</span>
			</a>	</div>
</article><hr class="mh-separator">
		</div></div><div class="sb-widget clearfix"><h4 class="widget-title"><span>Donate to The Grapevine</span></h4><p>Community journalism can NOT exist without some help from you, our loyal viewers.</p>
<!-- Begin PayPal Donations by https://www.tipsandtricks-hq.com/paypal-donations-widgets-plugin -->

<form action="https://www.paypal.com/cgi-bin/webscr" method="post">
    <div class="paypal-donations">
        <input type="hidden" name="cmd" value="_donations" />
        <input type="hidden" name="bn" value="TipsandTricks_SP" />
        <input type="hidden" name="business" value="escondidograpevine@gmail.com" />
        <input type="hidden" name="item_name" value="Every dollar goes to creating a better local news experience." />
        <input type="hidden" name="item_number" value="escondidograpevine-facilitator@gmail.com" />
        <input type="hidden" name="rm" value="0" />
        <input type="hidden" name="currency_code" value="USD" />
        <input type="image" style="cursor: pointer;" src="https://www.paypalobjects.com/en_US/i/btn/btn_donateCC_LG.gif" name="submit" alt="PayPal - The safer, easier way to pay online." />
        <img alt="" src="https://www.paypal.com/en_US/i/scr/pixel.gif" width="1" height="1" />
    </div>
</form>
<!-- End PayPal Donations -->
</div></aside>
</div>
</div>
<footer class="mh-footer">
		<div class="wrapper-inner clearfix">
			</div>
	<div class="footer-bottom">
		<div class="wrapper-inner clearfix">
							<nav class="footer-nav clearfix">
					<div class="menu-footer-navigation-container"><ul id="menu-footer-navigation" class="menu"><li id="menu-item-513" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-513"><a href="https://www.escondidograpevine.com/advertise/">Advertise</a></li>
<li id="menu-item-517" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-517"><a href="https://www.escondidograpevine.com/about-us/">About Us</a></li>
<li id="menu-item-43" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-43"><a href="https://www.escondidograpevine.com/sitemap/">Sitemap</a></li>
<li id="menu-item-514" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-514"><a href="https://escondidograpevine.com">Home</a></li>
</ul></div>				</nav>
						<div class="copyright-wrap">
				<p class="copyright">Copyright 2021 | MH Newsdesk by <a href="http://www.mhthemes.com/" title="Premium Magazine WordPress Themes" rel="nofollow">MH Themes</a></p>
			</div>
		</div>
	</div>
</footer>
<div id="aioseo-admin"></div>
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/www.escondidograpevine.com\/2021\/01\/12\/justice-for-rosies-hit-run-suspect-arrested\/":23757,"https:\/\/www.escondidograpevine.com\/donate-to-the-escondido-grapevine\/":15268,"https:\/\/www.escondidograpevine.com\/2019\/08\/12\/woodstocked-celebrates-hippiedom-while-raising-funds-to-locate-missing-persons\/":18369,"https:\/\/www.escondidograpevine.com\/2019\/07\/23\/community-news-for-the-rest-of-us\/":18164,"https:\/\/www.escondidograpevine.com\/2018\/03\/06\/home-decor-imports-where-astrophysics-meets-accent-pieces\/":3621,"https:\/\/www.escondidograpevine.com\/2016\/09\/05\/modest-proposal-support-the-grapevine\/":8269,"https:\/\/www.escondidograpevine.com\/2016\/03\/15\/join-these-escondido-grapevine-sponsors\/":4827};
	</script>
							<div id="sharing_email" style="display: none;">
		<form action="/2021/01/12/justice-for-rosies-hit-run-suspect-arrested/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			
			<img style="float: right; display: none" class="loading" src="https://www.escondidograpevine.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel" role="button">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<link rel='stylesheet' id='mediaelement-css'  href='https://c0.wp.com/c/5.5.3/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='https://c0.wp.com/c/5.5.3/wp-includes/js/mediaelement/wp-mediaelement.min.css' type='text/css' media='all' />
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/9.3/_inc/build/photon/photon.min.js' id='jetpack-photon-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.5.3/wp-includes/js/comment-reply.min.js' id='comment-reply-js'></script>
<script type='text/javascript' id='jetpack-facebook-embed-js-extra'>
/* <![CDATA[ */
var jpfbembed = {"appid":"249643311490","locale":"en_US"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/9.3/_inc/build/facebook-embed.min.js' id='jetpack-facebook-embed-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.5.3/wp-includes/js/wp-embed.min.js' id='wp-embed-js'></script>
<script type='text/javascript' id='mediaelement-core-js-before'>
var mejsL10n = {"language":"en","strings":{"mejs.download-file":"Download File","mejs.install-flash":"You are using a browser that does not have Flash player enabled or installed. Please turn on your Flash player plugin or download the latest version from https:\/\/get.adobe.com\/flashplayer\/","mejs.fullscreen":"Fullscreen","mejs.play":"Play","mejs.pause":"Pause","mejs.time-slider":"Time Slider","mejs.time-help-text":"Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.","mejs.live-broadcast":"Live Broadcast","mejs.volume-help-text":"Use Up\/Down Arrow keys to increase or decrease volume.","mejs.unmute":"Unmute","mejs.mute":"Mute","mejs.volume-slider":"Volume Slider","mejs.video-player":"Video Player","mejs.audio-player":"Audio Player","mejs.captions-subtitles":"Captions\/Subtitles","mejs.captions-chapters":"Chapters","mejs.none":"None","mejs.afrikaans":"Afrikaans","mejs.albanian":"Albanian","mejs.arabic":"Arabic","mejs.belarusian":"Belarusian","mejs.bulgarian":"Bulgarian","mejs.catalan":"Catalan","mejs.chinese":"Chinese","mejs.chinese-simplified":"Chinese (Simplified)","mejs.chinese-traditional":"Chinese (Traditional)","mejs.croatian":"Croatian","mejs.czech":"Czech","mejs.danish":"Danish","mejs.dutch":"Dutch","mejs.english":"English","mejs.estonian":"Estonian","mejs.filipino":"Filipino","mejs.finnish":"Finnish","mejs.french":"French","mejs.galician":"Galician","mejs.german":"German","mejs.greek":"Greek","mejs.haitian-creole":"Haitian Creole","mejs.hebrew":"Hebrew","mejs.hindi":"Hindi","mejs.hungarian":"Hungarian","mejs.icelandic":"Icelandic","mejs.indonesian":"Indonesian","mejs.irish":"Irish","mejs.italian":"Italian","mejs.japanese":"Japanese","mejs.korean":"Korean","mejs.latvian":"Latvian","mejs.lithuanian":"Lithuanian","mejs.macedonian":"Macedonian","mejs.malay":"Malay","mejs.maltese":"Maltese","mejs.norwegian":"Norwegian","mejs.persian":"Persian","mejs.polish":"Polish","mejs.portuguese":"Portuguese","mejs.romanian":"Romanian","mejs.russian":"Russian","mejs.serbian":"Serbian","mejs.slovak":"Slovak","mejs.slovenian":"Slovenian","mejs.spanish":"Spanish","mejs.swahili":"Swahili","mejs.swedish":"Swedish","mejs.tagalog":"Tagalog","mejs.thai":"Thai","mejs.turkish":"Turkish","mejs.ukrainian":"Ukrainian","mejs.vietnamese":"Vietnamese","mejs.welsh":"Welsh","mejs.yiddish":"Yiddish"}};
</script>
<script type='text/javascript' src='https://c0.wp.com/c/5.5.3/wp-includes/js/mediaelement/mediaelement-and-player.min.js' id='mediaelement-core-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.5.3/wp-includes/js/mediaelement/mediaelement-migrate.min.js' id='mediaelement-migrate-js'></script>
<script type='text/javascript' id='mediaelement-js-extra'>
/* <![CDATA[ */
var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/","classPrefix":"mejs-","stretching":"responsive"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/c/5.5.3/wp-includes/js/mediaelement/wp-mediaelement.min.js' id='wp-mediaelement-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.5.3/wp-includes/js/mediaelement/renderers/vimeo.min.js' id='mediaelement-vimeo-js'></script>
<script type='text/javascript' id='sharing-js-js-extra'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/9.3/_inc/build/sharedaddy/sharing.min.js' id='sharing-js-js'></script>
<script type='text/javascript' id='sharing-js-js-after'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-tumblr', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-pocket', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcompocket', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-telegram', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtelegram', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-skype', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomskype', 'menubar=1,resizable=1,width=305,height=665' );
				return false;
			});
</script>
<script src='https://stats.wp.com/e-202102.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.3',blog:'99274563',post:'23757',tz:'-8',srv:'www.escondidograpevine.com'} ]);
	_stq.push([ 'clickTrackerInit', '99274563', '23757' ]);
</script>
</body>
</html>